Roon Win10 installer is "unable to start correctly"


I have a trial account and I can’t start installer (32 and 64 are both identically non-starters).

If I try using administrative privileges the above application error does not appear, but the installer is definitely not running any further. I assume I am doing something wrong, but I really have no clue.

My system infos:
win10 64bit, version 1709, usable max ram 15,5gb, cpu is i7-4785T, Asrock H97 motherboard.
2 GPU’s in use, dual screen extended desktop:
Nvidia GTX1060 6GB --> 2560x1440
Intel iGPU “HD Graphics 4600” --> 1920x1080
DAC: Arcam rDAC via USB.

I have a realtek ethernet port directly connected to 100mbit cable modem, no VPN, but I do have F-secure SAFE (tried disabling antivirus and windows firewall, but no effect).

I looked at some old posts on forum and I already tried forcing Nvidia GPU to handle openGL (no effect whatsoever).

This pc has a research application Nvivo installed (which is using SQL server), and also several office and browsers, f.lux etc apps running. Current free mem is about 9,5 gb. There are also some junk MSI & Nvidia applications for my graphics card.


Please try:

Please disconnect all monitors save one attached to Nvidia 1060.
Please disconnect the DAC.
Please run installer as Administrator.

After successful install, please reconnect the second monitor and the DAC.
The second monitor might be the culprit.


Thanks for the advice.

I tried with one display only: first with intel gpu only and then nvidia only, no luck. Also dac was disconnected.

I had a look at the techcrises link: windows sfc scan found zero errors but dependency walker listed over 500 files missing when I load the roon installer.

I don’t know if it helps, but the list of dll’s is here:

I decided to forget the windows installer problem and try linux server + ipad remote instead.
This alternative seems to work really well at the outset. I will return to troubleshooting my windows issue later.

Thanks everybody for your help so far.


You might need to reinstall the .NET runtime, it looks like.
Did you perhaps turn it off?


I’m having this problem as well. Nothing I’ve done has worked. Searched google and followed some advise found there and still nothing. I run the installer as administrator the install asked for admin privilages and then nothing happens.

Trying to get my free trial going but they way this is starting I’m not feeling to keen to fork over 120 bucks a year for this.

I think this is your problem. There was something similar: Recovering from failed update [Resolved] .

Of course, we don’t know how things got lost. As for the missing DLLs, you may have to re-install Windows (or revert to an earlier level).

Another possibility is SFC.exe. See .

Thanks for posting this, I’ll give it a try later today when I get home. I’m really wanting to get this fixed so that I can try Roon out, really sounds like a great app.