Roon with Denon AVR Just Hangs

Core Machine (Operating system/System info/Roon build number)

Windows 2019 Server as a PDC, VMWare ESXi 6.5, 1.7 528

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Uniti Edgeswitch 500 48, Ethernet Wired

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Denon AVR-X6300H (Airplay)

Description Of Issue

Server and remotes all work fine. Denon is detected as a Roon Tested device and can be selected. When I go and play any file (whether Local or through Tidal) the file just hangs. The play button changes to a pause (indicating it’s trying to play) however the cursor does not move and I get no sound. I can move the cursor to anywhere in the file but again it just doesn’t move and I get no sound.

I’ve tried everything I can think of to get it to work including opening the firewall on the server to all three Roon applications. No idea what else to try or how else to troubleshoot. I’m highly technical so packet captures and traces are not out of the question as long as I know what I’m supposed to be seeing.



Has this worked before or is this a new installation?

It’s a brand new installation and has never worked. I’m still on the trial so evaluating whether I want to sub or not. I’m impressed so far but it’s a little flaky in places.


Just a thought, but the “Roon Tested” capability has just been recently announced by Denon & Marantz. Could it be that your Denon needs a firmware upgrade?

Hello Gary and welcome. I’ve used the the Denon Airplay zone in the past before the Roon Tested specification and before I ran an HDMI connection from Nuc to receiver for multi-channel playback.

With the receiver on, processing the cable setup to the TV, selecting the Denon airplay zone on the Roon Remote and playing an album the receiver would automatically switch to the airplay function with the album/track information displayed on the TV and the music played. It was that simple as I recall.

I don’t see a wireless router specified in the Network details. What do you have for wireless?

Not sure if there are any unique actions for Airplay over Ethernet. Have not tried that.

No I don’t believe there is an updated firmware I checked yesterday and I was on the latest one.

I have wireless only neither the Core nor the Denon use it as they’re exclusively Ethernet. Just for sanity (and something I didn’t try before) I just tried an IPad I have and that worked first time flawlessly. Just play a track, select Airplay, select the Denon and bang it just worked.

The only thing I can think of is that the server is blocking the connection to the AVR on the ports I need but the server can ping the Denon without a problem.

Any other ideas?


Just looking now netstat -b only shows a single connection to the AVR coming from port 58154 going to port 55135. I have specifically allowed the roonappliance.exe the ability to connect to and from anything so it should allow it. Wonder if there’s a way to test if that’s the problem.


Hi @Gary_Hopkins,

Can you share a screenshot of Device Setup for this device as well as a screenshot of the Signal Path when you start playback?

Sounds like your network might be blocking something that Roon needs. Roon needs multicast to be active and mdns, your using a Ubiquity Edge switch which is a managed switch so maybe need some tweaking .

The switch is pretty open. Everything else (and I mean absolutely everything else to multiple device) works perfectly fine including Airplay from an IPad on the same network.

I do suspect it’s something on the Server firewall but I’m pretty sure I’ve opened it up (and every other service on the server for Roon works fine, just not Airplay to the AVR.


Are you running roon in a vm? Using bridged network? Do you have more than one nic on the host? I’ve long forgotten what I know about all that, but recall having to mess with it to get udp and other stuff working.

It is in a VM but as I mentioned everything else is working, TCP and UDP. It’s not bridged as it’s on an ESX host so there’s a virtual port group for that network card. As certain as I can be it’s nothing to do with the VM.


Hi @Gary_Hopkins,

If you install iTunes on the VM, are you able to use that to stream to the Denon via Airplay?

Can you please try installing Roon Core on one of your remotes and verify if the same issue occurs outside of the VM on a standard OS?

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

Many thanks for the reply. The irony of the following isn’t lost on me.

Over the weekend I had a catastrophic disk failure which completely killed the server and the disk it was on along with Roon. Since getting a new disk and rebuilding it I turned off all the security and it’s now working. I can not only see and Airplay on the AVR I can also see and play on my Nvidia Shield through Chrome

My guess is (and was to be fair) that the firewall was blocking something despite opening all the ports that the program stated it needed and allowing the three Roon apps open access.

I am now more than happy with it and many thanks for all the great suggestions. Not exactly a solution as such (as it would be better to keep the firewall up) but as it’s far behind my security I’m not too bothered.

Many thanks again


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.