Roon with Google wifi

I am using a sonicorbiter os i7 as my core and it has storage built in.
I control the core using an iMac running mac os high sierra and various ipads all using the latest os. Network is wired with a few unmanaged switches.
All was well until google wifi replaced BT whole home wifi yesterday.
I could note use ipads to control roon although the iMac was still ok to configure sonicorbiter and run roon remote. Having spent some time with google support (very helpful) we connected the sonicorbiter direct to google wifi and reserved the ip address, after which the ipad worked with roon. Sadly the imac cannot now control the sonicorbiter nor run room remote. Also only 1 ipad of 3 i have checked appears able to connect to roon.
Any thoughts?

Can you clarify your current network… does “network is wired with a few unmanaged switches” apply in the new Google setup? I’m using eero which is similar to Google and no issues. Your mesh is transparent to anything running on it so something seems amiss.

Do you have some devices wired to non Google WiFi routers?

My router has IP addresses of 192.168.1.x while Google WiFi is 192.168. 86.x. I find that Roon seems to like everything to be connected to the Google WiFi - either wired or wireless.

Probably worth adding @support to the thread?

Thank you. I have just noticed that i can access the ‘manage’ page on the Ultrarendu under my Sonicorbiter,but the Sonicorbiter itself ‘manage’ page always times out without connecting.

Make sure your network switch is plugged into the Google Wifi AP and not the other way around. Google WiFi uses a 192.186.86.xx range that cannot be changed so it should be managing DHCP and assigning LAN IPs.

Hi Rob,
The google wifi is wired to the netgear gs105 unmanaged switch directly, can this be the other way round?

Your isp router should plug into the Google WiFi AP (the primary node) directly and then you should use the second port on the Google WiFi AP to plug into a LAN port on the Netgear.

When you open up the Google WiFi app, you should see all your devices (both wired and wireless) connected. You could actually try this first to validate this is your issue. It certainly sounds like it.

I have the system connected as you suggest. I do see several devices on the google wifi app.
However i cant see my imac on the list (it is connected to the same switch as the google wifi) nor can i connect to the sonicorbiter page on my imac or access roon remote on the imac. The imac connects to the internet happily enough via the router connected to the google wifi and then to the switch.
I can access both roon remote and sonicorbiter on my ipads however.
I have just tried turning wifi on on the imac and connecting to the google wifi, instead of over the wired connection. Immediately i am able to connect to the sonicorbiter and roon remote! So it would seem all is well, although i am still not sure why the wired connection is not working!
Thanks to all for the guidance.

Jeremy, I do not think you have your network topology ordered per Rob’s instructions.

No: modem -> switch -> iMac, Google WiFi, etc.

Yes: modem -> Google WiFi -> switch -> iMac, etc.

Roon will not function with a double NAT and two parallel subnets.



Hi Andrew,
Thanks. I have the second set up (Yes:) however it seems to be working now, albeit with the imac connecting to the google wifi over wifi rather than ethernet.

Using Wi-Fi will force the iMac to the Google WiFi router subnet. But as long as you have wired everything using the second configuration above, Ethernet should function the same way. If you have not rebooted the iMac, that could be the issue. A reboot may be necessary to grab a new IP address.


Does your modem have wired ports? What do you have plugged into them? Basically the only thing that should be plugged into the modem router is the Google WiFi. Everything else should plug into Google.

1 Like

I will try the reboot and report back.

I have the google wifi set up as you describe. As noted its working now although the iMac is running on wifi instead of wired, although i aim to try andrew’s suggestion of a reboot shortly.

I have just turned the wifi off on the iMac and roon is still working happily and i can access the sonicorbiter. I can also access roon and sonicorbiter on the ipad so all seems well.
Thanks for all the assistance!

1 Like