Roon with Windows Desktop and Cambridge Audio DAC Magic 100

Core Machine (Operating system/System info/Roon build number)

Windows 10 Pro 10.0.18362 Build 18362
RoonServer v 1.7 (Build 505) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Gigabit network all hardwired. Im running from my roon server to a switch, to the main router/hub and back to my desktop pc. Network connections have all be tested and it is in fact running as a gigabit network.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Cambridge Audio DACMagic 100 connected via USB. Dac is connected to a pair of AudioEngine 2

Description Of Issue

I am looking at the streaming quality from Tidal. I can see the source is FLAC, then handled at the RAAT layer and is still at FLAC level. Then when it outputs to my DAC it appears as if if the OSMixer sets it down to HighQuality.

However do not use System Output and go direct to the DAC. I can get it to play and keep the lossless. however I loose all volume control from my pc at that point and have to turn the knob on the speakers, which kind of defeats having a DAC connected to a pc.

Is this the expected user experience? How can I get lossless streaming to my DAC from Roon as a windows system Output?

Second item is I dont see my DAC as a listed device for Cambridge Audio devices when I am attempting to configure this set up.

How do I explicitly choose the DAC Magic100 as my audio output or if I can not do that, what DAC should I be using in its place?

Hello @Matthew_Weyland,

Welcome to the forum.

OSMixer will always display “High Quality” instead of lossless, please see out explanation for this in our Knowledge Base:

While the Mac software mixer does not do anything too gross, it might be performing software-based volume adjustments or sample rate conversion before playing the audio. As such, we can’t guarantee that the output quality is lossless, so we label it as “High Quality”.

Can you share a screenshot of your Device Setup tab when you have the output set to the DAC directly? Device setup looks like this for reference:

Do you have “Fixed Volume” set for Volume Control or “Device Volume”/“DSP Volume”?

Where is the Cambridge DAC being connected to, directly to the RoonServer PC or to the Client? Can you share a screenshot of what you’re seeing in Roon Settings -> Audio?

The device is connected to my PC which is different than the Roon server, which is another room.

I did a screen capture of my audio configuration and the settings screen for the device. It does not look identical to yours as it doesn’t allow for MQA capabilities.

Hello @Matthew_Weyland,

In the Settings > Audio screen, try enabling the “CA USB Audio” zone and checking the Device Setup screen for that zone. This is the “WASAPI” zone for your device, which allows for “Exclusive Mode” playback. The “System Output” zone is always routed through the OS mixer, similar to if you were to play a YouTube video in your browser.


I did try using that output. Unfortunately the only way I can control my volume is the speakers themselves. They are a powered pair of audioengine 2. I was hoping there was a way to control them via my system volume control vs. the Volume control on the speakers themselves. Thanks for your prompt response.

Hello @Matthew_Weyland,

It will not be possible to have the volume attenuated in software without Roon displaying the “High Quality” Signal Path status.

There are two options that could address your desired functionality, at least partially:

A) Use the Volume Leveling feature in Roon to keep the audio output at a consistent volume, reducing the need to change the volume.

B) Another (potentially risky) option for software volume control would be to use Roon’s built in DSP volume and play to the device in Exclusive Mode. To do this, navigate to the “Device Setup” screen for the DAC Magic zone, change the “Volume Control” setting to “DSP Volume”.

The risk involved with this scenario involves playing audio to the device when Roon is not the active source. Applications without their own volume controls will play to the device at full volume, potentially damaging your speakers.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.