Roon won’t open on Mac. Error message “Can not create required lock file”

Roon Core Machine

Mac.

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I can’t open Roon on my Mac. All I get is the error message on the attached screenshot.

One cause can be the incorrect permissions on your tmp directory, i.e., no permission to write to that directory for that user.

The Roon connection has been working for months on the Mac.

The Nucleus can still read and update my Music folder from the Mac.

Both remotes work and connect to Roon. I am using it on the iPad remote right now.

That said, I wish I knew how to access my tmp directory and how to permit myself to access my Roon connection on my Mac.

Hey Ben,

Have you tried to uninstall Roon and reinstall then allowing the permission this time?

Ben,

The statements are confusing since in your opening post, you stated that your Mac was your Roon core, and you mention having a Nucleus which is a core. Can you detail exactly how you have this setup, and which one are you actually using as the Core?

Sorry for the confusion. The core is on my Nucleus. But for the past few days, I have not been able to access it from my Mac.

1 Like

Hey @Ben_B_Floyd,

In checking your System Diagnostics your Mac isn’t showing up in your Roon system at all. Can you please try reinstalling the Mac Roon Remote from our Downloads page and see if that helps?

Jamie,

Thanx.
I have already tried reinstalling.
No worky.

Ben

Hey @Ben_B_Floyd,

In checking your system diagnostics it looks like you were able to clear the stoppage and install Build 923 on your Mac. I’m hopeful that’s the case! Can you send us a status update, please?

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.