Roon won’t play DSD without converting to PCM with Questyle CMA400i [Resolved]

It knows that a plain DAC is connected, and it plays files very well, but this DAC goes up to DSD128 as well, and Roon does not seem to decipher those files as anything other than PCM. Audirvana does just fine with them. Any plans to include DSD in Roon? Or am I doing something wrong?

In general, Roon’s support for DSD is good, so it’s probably something specific to your environment. Might be helpful to start with screenshots of your signal path and device settings.

I use a Mac, and since first writing I’ve read on Roon’s website that "DSD converted to PCM in Roon, sent as PCM to your DAC,” while "DSD-Direct (DSD-Native) using ASIO drivers on Windows.” In other words, There’s no DSD conversion on Macs. I guess that’s my answer. Sorry I didn’t mention this at the beginning.

DSD works fine with Roon Core running on a Mac. If the DAC is directly connected to the core, though, you just need to use DoP. I’m not speculating here, this is all from direct experience.

I do believe you. I’d appreciate some help about how to go about doing this?

Is is possible for you to post screenshots of your signal path and device settings? That would really help with pinpointing the problem.

I cannot seem to post jpegs here. Here’s my path with Roon.

  1. Roon logged onto via MacBook Pro
  2. USB out to Questyle DAC via Chord USB cable.
  3. Questyle connects to analog input on T+A amp, then to speakers.
    All files play, but DSDs appear on my DAC indicator as 44.1K PCM files.

With Audirvana (same path) I simply drag any of my DSD files, including ISO packages, into the playing queue and press play. Voilà.

Changing any of the Sample rate options that I am allowed to on my Roon settings does not seem to alter the nature of the signal going through the DAC, and I do not see any DoP options anywhere.

Any suggestions?

Hope you are having a great Christmas. I really appreciate your help.


Those screenshots would help a lot. When you’re posting or replying here, this icon…


… is the gateway to uploading.

Meanwhile, though, in your settings for Device Setup, is there an item for “DSD Playback Strategy” or something to that effect? That’s what I’m interested in. (I’m at kind of a disadvantage here, since all my Roon zones are network zones, and the only DACs I can easily hook up directly to my iMac are not DSD capable.)

I took several screen shots at various stages of the setup process, including device setup if you dig a bit deep. But I did not see anything referring to Playback Strategy. Maybe you can point me in the correct direction. BTW, you have good playback stuff.

Hi Bob,

It looks as though you are showing Device Setup for your System Output (Bob’s Office) Zone. Are you playing to that zone? What zone are you seeing at the bottom right of the Roon screen, next to the volume icon?

You want to select Questyle zone and check its Device Setup. The DSD Strategy is found under Playback tab.

Cheers, Greg

Hi Greg: I’m playing to Bob’s Office, and that’s what the lower right hand indicates. I changed to the Questyle zone, and am listening to it. Progress!!! :wink:

Now then, what Playback tab are you referring to? Can’t seem to find it even though it’s undoubtedly staring me in the face.

Thx, Bob

1 Like

Hey Bob,

Right click on the Questyle zone icon at the bottom right and select Device Setup. There you will see the Playback tab. You should see DSD Strategy under that tab. You probably want to select DSD over DOP.

After you do this, try playing a DSD track and click on the coloured dot to the right of the track at the bottom middle of the screen. This is your Signal Path. Please show us a screenshot of that window.

Cheers, Greg

Thanks. Company has just arrived. more later tonight or tomorrow. Progress continues. Who knew about right-clicking???

As you can see, there is no DSD Strategy under the Playback tab, or anywhere else I can find.

I’ve also included the signal path you requested.



Hi Bob,

A couple of things. First, click Exclusive Mode to Yes and second, can you post a screenshot of the top of the General tab?

Cheers, Greg

1 Like

Just in case you meant the Playback tab, I included it too.

Hi Bob,

Yes, the Playback tab. We need to change those yellow DSD’s to Green. Usually that could be done with the DSD Strategy option.

I’m not sure where to go from here. I’m going to ping @support to help out.

Cheers, Greg

Many thanks Greg.

Moving to Support category.

Cheers, Greg

Hi @Bob88 ----- Just wanted to touch base with you real fast as you should be given to the option to chose your “DSD Playback Strategy” when “exclusive mode” is enabled. Please see below and let me know if you are seeing something different, thanks!

MacBook Air = Roon Core
Endpoint = PS Audio Perfect Wave (via USB)

Playback Tab - > “Exclusive Mode” disabled:

NOTE - As you can see with “exclusive mode” disabled I am not given the option to select a DSD playback strategy.

Playback Tab - > “Exclusive Mode” enabled:

NOTE - As you can see with “exclusive mode” enabled I am now given more playback settings and the option to select a DSD playback strategy is also available.


1 Like