Roon won’t recognize my Tidal login

I have tried 20 different ways. I have rebooted my core. I have rebooted my computer I have logged out of TIDAL. I have changed by TIDAL PASSWORD. TIDAL logs in on all my devices (iPhone, iPad, desktop), just not in any of my roon interfaces. The login page says the connection has been made but when it sends me back to the app it shows the Login or Start Free Trial screen.

I have a ROCK on a Nuc8i3 with 8gb ram + 2tb internal ssd connected to iMac Core i5 over Ethernet cable and other devices via WiFi.

Every time I put in my TIDAL username and password and it redirects back to the app and does not register my TIDAL account in Roon and thus none of my saved Tidal albums are available.


I had the same issue but I’m not convinced that I can provide you with a solution.

What finally worked, but may have simply been random chance was when I logged on to the Tidal app from my PC and had that connection.

Then, when I entered my credentials into Roon it finally started to work the way it should.

I tried numerous times without success and was ready to give up. All of a sudden it started to work and has done so flawlessly ever since.

I always wondered if the difference was going from a trial version to a full Hi-Fi subscription. It shouldn’t make any difference but who knows?

For me it worked at the beginning for about a week and then just stopped when my home internet experienced a blackout for about a day. It simply never reconnected.

Maybe try changing your password with Tidal - logoff and then back on.

I tried this twice. It didn’t make a difference. When is support going to chime in here? I thought Room had legendary customer support???

I suspect it’s a Tidal thing, not a Roon thing. I don’t have any more suggestions for you.

Best of luck, my friend.

Tagging @support

Hello @Matthew_Merewitz, and thanks for your report! Are you running the latest build (571) of Roon?

Yes I am. How do I delete Cache? Can you walk me through it? I tried doing it on the desktop and it just copied the files somewhere else. It did not delete Tidal_CACHE.

It’s been almost two weeks now with no Tidal Access in my Roon. Works everywhere else on all computers and iPhones/tablets.

Hello @Matthew_Merewitz, in just a moment, I’m going to send you a PM, please check it out!

1 Like

Hello @Matthew_Merewitz, could you please send me a screenshot of the WebUI? Also, have you tried google or cloudflare DNS?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.