Roon won't control Bluesound Node2i

Core Machine (Operating system/System info/Roon build number)

MacMini (late 2018 i5) running Roon 1.7 Build 528
Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

MacMini connected on Wifi (but also tried ethernet wired into Netgear Router and problem remains the same).
BTHomeHub5 connected to external phone/internet line. Wifi switched off on this router.
Homehub5 wired to Netgear R7000 router which runs all the wifi in the house.
Sonos and Bluesound wired into the routers

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonos Connect Wired into Netgear Router
Bluesound Node2i wired into the BT router (also tried wireless connection and problem remains the same)
Music stored on NAS wired into the Netgear router

Description Of Issue

Roon happily plays on the core, and on the sonos system, but won’t play on the Bluesound. Using the Bluesound app I can play music direct on the bluesound, but can’t via Roon.

When I put music on using the Bluesound app, Roon will show what is playing, will see it changing songs, and will see pause / play.
When I try via Roon it all appears to work, but no sound comes out. The Bluesound app can see what is supposed to be playing via Roon, but no sound comes out.

The bluesound player is connected to an external amp via the RCA outputs.

Problem is the same on Tidal or NAS music.

The family connects to the Bluesound player using Spotify Connect.

I’ve done a full factory reset on the Bluesound, and a full remove and reinstall of Roon, including removing the Roon Folders.

I did have a RPi connected (and maybe grouped with Bluesound) but the SD card has corrupted and new one on order, so I can’t see if there is still a background grouping with that that is causing an issue. That’s why I did a full uninstall / factory reset to try and remove any background links.

Need some help as don’t know what else to try.

Bluesound did work fine via roon up until the RPi failed.

Hi @Jon_Arch,

Welcome to the forum! Can you confirm that your Node 2i is on the latest firmware version according to the BluOS app?

If it is on the latest version, I would like to take a look at diagnostics regarding this issue, can I please ask for the following?

  1. Reproduce this issue and note the exact local time + date + track you tried to play that exhibited this behavior.

  2. Access your Roon logs by using these instructions.

  3. Access you Bluesound logs by using these instructions:

You can get these logs by navigating to Bluesound’s IP Address in a web browser -> Diagnostics -> More -> Copy+ paste the text into a text editor

  1. Upload both log sets to Dropbox / Google Drive / and post a link here.

Any questions or difficulties retrieving these logs, just let me know and I can clarify, thanks!

I may have completely misunderstood but I wonder whether this may be your problem - is the Homehub giving the Bluesound an IP on a different subnet? What happens if you wire it to the Netgear router instead?

It may have self corrected - I will try and repeat the issue tonight.

Last night I tried to play a file via Bluesound and it asked me to perform a software update as there was a new version out (3.8.8). I then played a file via Roon and, as normal, it wouldn’t work, but I forgot to record the time of this.

Later on I was messing around with my son and different music, and he was playing music via Spotify Connect with me fighting for control via Bluesound. I lost.

Then later on I went to play a file via Roon and it all worked as normal. So I wonder if it was a Spotify control issue, with his phone keeping the connection ‘locked’? Still doesn’t explain why the blue sound app showed my music in its playlist but no sound was coming out.

Then Boris came on the news and announced the country is being locked down, which meant I didn’t get chance to do any more investigation. I will try again later on today to see if it is Spotify and will repost.

I did think about this but thought that I had checked this out by going wireless. As only the Netgear router has wireless switched on, then the wireless connection would automatically test this scenario?

Also not sure how I would identify a different subnet? Can you provide more details?

I’m an enthusiastic amateur in relation to tech and wireless, and have a relatively high success rate in fixing things, and also a relatively high failure rate which then requires me to start connecting wired into the routers to undo whatever setting I had switched on / off to see what happens!


You may well be right but others have reported difficulties with Wifi on the Node 2i so I thought it was worth a shot in terms of narrowing down the problem.

As to subnets I would just double check with an app like Fing that you can ‘see’ the Node. Normally you’d only plug devices into one router but in your case it looks like you are effectively using 2.

Hi @Jon_Arch,

If Spotify had control of the Node 2i, I would not expect the progress bar to proceed at all.

Thanks for the update here! If the issue re-occurs please do send the above diagnostics info.

Yes, tried that and can definitely see the node.

further post now added as problem is reappearing

Issue repeated itself tonight. All was playing fine on Roon, then I let my son play some music via his Samsung phone and the Spotify app.

Bluesound app will stop and start the music fine.

Roon App shows the playbar advancing but no music coming out of the Node2i.

19:57 was when I started playing via Spotify


Ah, well in that case I’ll bow out and leave you in the capable hands of the experts :stuck_out_tongue_winking_eye: That said, if it were me, I’d stick to one router to minimise the scope for problems (I have a similar setup with a BT Homehub effectively acting as a modem and another router connected to it which manages my LAN).

Thanks for your help on this. I’d tried about 50 things, so extra things to try are always welcome


1 Like

Hi @Jon_Arch,

Thanks for sending the logs over, I have requested the technical team review them and once that’s done we will follow up once more.

Hello @Jon_Arch,

Looking at the Bluesound logs, we see an on-device error occurring at the time of the playback failure:

Mar 24 19:57:39 (none) dspout: [error] ALSA lib pcm_hw.c:649:(snd_pcm_hw_drain) SNDRV_PCM_IOCTL_DRAIN failed (-11)

We are not experts at interpreting Bluesound logs, I recommend bringing this report to the Bluesound support team with your Bluesound diagnostic logs to see what they think is causing this error.

I have also scheduled testing in the QA lab for the Bluesound NODE 2i and the Spotify Connect behavior you are reporting. If we are able to reproduce this issue with our in-house unit we’ll be sure to let you know.


I’ve managed to get it working again.

The Airplay device on Roon for the Bluesound was disabled. I have reenabled it, played some music via Airplay, stopped the music and then disabled it again.

All seems to be working fine. I will post more if it breaks again.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.