Roon won't find core suddenly

Roon Core Device


Networking Gear & Setup Details

Orbi RBR750
TPlink switch.

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I start the Roon app and it won’t find the Roon Core on ROCK.

The iMac is not seeing the ROCK under networks. I tried a different switch. No luck. Also, rebooted and replugged ROCK multiple times. Firewall is off on iMac.

I just replaced my router but not sure why this would matter tho.

Cannot connect via SMB either :frowning:

Peter, did this begin after you replaced your router? Also, can you please provide some additional information about your network, including what is wired to the Orbi and what is using WiFi? I’m assuming all devices are connected to your Orbi system.

In your new router’s administration page, do you see the iMac and the NUC ROCK? Do they share the first three IP network address numbers (e.g., 192.168.1.x or 10.0.0.x)?

go back to the old router and connect to the GUI on the ROCK system… make sure the network is setup for DHCP and NOT static… have you restarted the rock? press power button to shut down… wait a min then press again to on it.

I do see the rock on the admin page. therebare various iOS devices on the wifi and a disk station Synology on the router hard wired, as is an Apple TV; all show up. all are connected to orbi.

the old router is not working but was set up as a static. I am having frontier come out to reinstall because the orb not reaching all may house but I can’t get it to work now. is there any way to deal with that now? I have restarted the rock many times. no good.

The ip address on the rock is the same one as before; it does show up on orbit app as being connected to network, but Roon on my iPhone and iMac won’t see it…

you need a HDMI monitor into the ROCK…or VGA whatever the system uses… and a keyboard…

ok I can do that. once I connect to it, what do I do please? Please be as SPECIFIC :slight_smile: as possible because I am a noob!!

If you built this rock then you should have done all but enter the command during setup

The instructions are pretty much as basic as it gets

Wizard, thanks. I built it about 3 years ago by painstakingly following directions step by step and am not by any stretch an expert :slight_smile:
once I plug in the rock to monitor and keyboard, do I just hit enter? I’m sorry to be dumb; I just don’t know how to handle the rock.

Also–critical: do I plug the rock into my router when doing this?

I appreciate any advice you can give!!!

No need to be on the router but it’s best if you are

Hit enter then type the command and hit enter.

You should be able to see the rock on the new IP address. If not reboot with the monitor connected to see the IP address it gets

ok, gulp, I’ll give it a try and report back!

You can do it :sunglasses:

ok I did it and it said that Roon OS Web UI can be directly accessed at

that was the old ip address and its still not showing up. I tried network reset twice.

It’s still not showing up on network, and if I try to access the rock page I get the swirling square; Roon won’t find it…


Hmmm…I hooked up the rock via HDMI and it verified that the IP address is

BUT: all my other devices are 192.168.1.x

How can I change the ROCK to be in this range??? This seems to be (part) of the problem.
I tried network reset to no avail


Finally did it. A few network resets finally assigned it an IP address in the right range!
Wizard, dude, many thanks!


Can mark as a solution…well done


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.