Roon Won't Open in Windows 10

Core Machine (Operating system/System info/Roon build number)

Roon ROCK on NUC (latest build, I believe)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet through Netgear Router R7800

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

For my computer system - USB/EGO Emotiva/stereo receiver (sound works in other apps)

Description Of Issue

Roon works fine except on my Windows 10 computer. Been running Roon Server for quite a while with no problems. Recently (perhaps after a Windows update?) it stopped working. The splash screen pops up for a few seconds and then disappears.
I tried removing User/Name/AppData/local info to another folder - same result
I did an install over the top of the old app - same result
Uninstalled - reinstalled - same result
Installed Roon Bridge - acted the same as Roon Server
Running Windows 10 Pro - Version 1903 - Build 18362.356

Hi @Daniel_Harper,

Since experiencing this problem have you tried rebooting the Windows machine? Besides a Windows update, was there any change to your setup?

If temporarily disable any firewall is there any change?

Uninstalling Roon completely (program and database)still leaves some information in the Windows Registry.
It has been my experience that, in order to be able to do a proper install of Roon, these entries in the Registry need to be cleaned.
I am using the free version of Ccleaner for that.
Maybe worth to try out.
And for the Roonlabs guys, please verify the Windows uninstall process.

Something doesn’t make sense to me. Roon Server doesn’t have a “splash screen”. In fact, it doesn’t have a UI. Neither does Roon Bridge. I’m not sure what you’re doing, but I don’t think it is what you think you are doing.

Thanks for the reply and apologies for my tardy response!

I’ve disabled the firewall with no success.
I’ve uninstalled and reinstalled with no success. I haven’t “searched and destroyed” every reference in the registry but I will try that next.

Another wrinkle to all this: I have a new photography app from Topaz Labs that is newish (I don’t think there is a connection) that also stopped working in much the same way. It quasi-launches and then nothing happens. So. I’m guessing a Windows 10 update went awry or I may need to research it from that angle.

Thanks, Dirk!
I will try to clean out my registry and try, try again.


Hi Geoff,

I’m sure I’m using the wrong term but when I say splash screen I meant the rotating musical quotes that pop up when the app opens. I running the core on a NUC and the Windows app is essentially just an endpoint.
Again, my Roon ROCK is running just fine it’s just working on my Windows machine.


It’s just NOT working on my Windows machine. Sheesh, my fingers slipped!!

Hi @Daniel_Harper,

Yes, this could definitely be due to a Windows update. Do you see any errors in Event Viewer for Roon after the crash?

I was hoping you could use the directions found here and send us over a set of logs using a shared Dropbox link. We will need logs from your Windows remote.

Thanks Dylan,

I’m guessing that the logs you want are gone, since I uninstalled my RoonServer app on my Windows machine along with all the settings. And cleaned the registry as best I could.
I DO have the logs on my Roon ROCK and have zipped them. Before I send them to you do you really want those logs from my NUC? If so, could I send you a link from Google Drive?
If you don’t want these Roon Rock logs should I reinstall my Windows Roon and then send that .log to you?
So many questions, sorry!!!

Dan Harper

Hi Dylan,
I reinstalled RoonServer on my Windows machine and so I now have a very small .log to send you.

Here is the Dropbox link:

Dan Harper

Wooohooo!! Success! I updated my drivers for my Nvidia graphics card. Go figure but it’s working! I’ll let it run for a while and see if anything goes wrong but I “think” the problem is solved!


1 Like

That’s great news, @Daniel_Harper!

If you see any issues return please let us know.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.