Roon won't play after upgrading my Mac mini server to macOS Sonoma 14.3

Roon Server Machine

Mac mini (2018) Core i7 32GB RAM running the recently released macOS Sonoma 14.3 (23D56)

Networking Gear & Setup Details

Wired 1GB switched Ethernet network into a fiber internet connection

Connected Audio Devices

Multiple Roon endpoints (iFi Zen Stream, various AirPlay devices, dCS Bartok) most wired via Ethernet.

Number of Tracks in Library

Around 27K tracks stored on a NAS.

Description of Issue

My system has been rocking along for a while, however, I installed the new macOS Sonoma 14.3 update last night (as it contains security updates) and found that Roon would no longer play. And, Tidal would no longer work.

The main symptom is that I can navigate on the Roon UI normally and select a track and press play. The playback control switches from the rightward facing triangle to the pause symbol but the track never starts playing. It just sits there looking lost with no playhead marching across the waveform. If you click on the gray colored dot that shows the playback details of the track, only the endpoint device name with no track details is displayed. Seems like maybe the RAATServer isn’t firing up?

BTW: This occurs with tracks stored on the NAS. Tidal doesn’t work anymore because it can seem to contact to the Tidal service. If I go to the Tidal tab in the sidebar of the Roon UI, it’ll just show the spinner icon as it tries to reach the service. I did logout of Tidal and try to re-log in from Roon’s Services menu. However, after a successful login from Tidal’s web UI, the Roon UI just gets stuck waiting for Tidal after returning to the app. I have confirmed that Tidal works fine on the same Mac mini via their own web-based player & that their app on my phone works when attached to the same network

Confirmed that the Mac mini has connection to both the LAN and the Internet/web. Also tried with macOS’s firewall disabled and experienced no change in the errant behavior.

Troubleshooting suggestions welcome!

Hi @The_Leisurely_Loris ,
Thank you for your patience while we worked through the queue. Please provide the date, local time, and the title of the track you were trying to play and we will activate diagnostics on your account to investigate this further.

Thanks in advance for you assistance. Since I’ve been unable to re-login through Roon to my Tidal account (it just sits at “Waiting for Tidal Login”), I wasn’t able to try and play anything from that service. So, at around 6:48AM PST on 1/27/24 I tried to play Mellencamp’s Rain on the Scarecrow (2022 Mix) from a the “local” music library on my NAS & then the Cars’ Just What I Needed after that. Neither track played demonstrating the same symptoms that I outlined in my original support request. I tried two different endpoints with the same results. Nothing plays.

Hi @The_Leisurely_Loris,
Let’s try disconnecting and reconnecting your network share. There have been some reports with Sonoma of issues with network shares. If that doesn’t work let’s try restoring the server with a backup using the instructions below.

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

@Daniel ,

Thanks for the troubleshooting suggestions.

I wasn’t able to test removing the network share as that is where all my purchased music files are stored & since Tidal also isn’t working that would leave Roon with no access to music.

I did confirm that Roon can access the files on the NAS as it begins it scan for music when the Roon app/server is launched. Also, the ‘RoonMounts’ folder that Roon creates in /Library for volumes it maps resolves to the appropriate shared folder on the NAS. I also confirmed that the Mac mini can effortlessly play music files on the network share through the Quick Look feature in Finder. So I don’t think the networks share is the issue.

Swapping the Roon folder per your instructions didn’t make a difference either. So, I continued to poke around and remembered that before installing the latest Sonoma Update, I turned off WiFi on the Mac mini as it’s not needed. The Mac is still connected via physical Ethernet to the same subnet, so turning off WiFi didn’t change its access to network resources. I can still login and remotely admin the Mac mini when it is on Ethernet & the Roon clients on other computers/devices can also still “see” RoonSever running on the Mac mini.

However, with WiFi turned on I can get Roon to play a music file stored on the NAS once. It will take about a minute or two after hitting the play control in Roon for the music to start. If you then pause the track & try to start playback again the UI gets “stuck” per my original problem description and no playback occurs. Tidal still is unable to login even with WiFi active.

All other network-based applications I run on my network and even other services I run on the Mac mini work fine. The problem is localized to Roon after I installed the Sonoma 14.3 update.

BTW: As an experiment, I multi-homed the Mac mini running acting as a Roon server with a second Ethernet connection (via a USB-C to Ethernet adapter). Didn’t make any difference to the above mentioned Roon playback behaviors although it made scanning the files on the NAS much quicker since the NAS is running SMB Multichannel. I also tried rebooting both the Mac mini and the NAS to see if that would help and didn’t have any luck getting Roon to play. I wonder if there is something funky with the latest version of Roon and its credentials? macOS security has tightened things like network access quite a bit. For example, I see that Roon is listed in the File & Folders section of the Mac’s Privacy & Security preferences, but not the RoonSever, RAAT, or any of Roon’s other essential parts.

@The_Leisurely_Loris, on further investigation I’ve noticed a few things. First there are traces of a failed request to another server for album art. Has album art been working for you at all? Second this looks like it may be a latent address resolution problem. Can you tell me what make and model of router you have and what DNS you’re using? Also have you had any other issues on your network with IP address assignment?

My router uses OpenDNS ( & for DNS lookups. As an experiment, I also just moved the Mac mini running Roon Server over to CloudFlare DNS ( by locally overriding its DNS settings. It didn’t change the behavior of the system from my initial report. Also, I installed the new macOS Sonoma 14.3.1 update & the latest Roon update from last week. Neither improved the situation. BTW: All DNS-related activities (such as web browsing) are working fine on the Mac mini.

BTW: it might be useful for you to look at the macOS Console to see what is there (you’ll have to enable message streaming when you open the Console app & search on “RAAT”). On my system RAATServer keeps on throwing an “macOS Error -25294” into the log which I think is some sort of certificate failure. Also, after I quit Roon (and the RoonServer), I see another error detailing an excess packet count from RAATServer.

Thanks for providing those steps we’ll pass it to QA to attempt to reproduce. While we do that can you explain your router setup to enable QA to reproduce the issue more easily?

The Mac mini running Roon (Server) is connected via 1 gig wired Ethernet to a 1/10 gig Netgear switch which also connects the Synology NAS. The Router isn’t involved in communication on the LAN unless traffic is inbound/outbound to the Internet. The router connected to the switch is a Peplink Balance 20x backed by a CenturyLink Fiber connection. Most of my endpoints are connected via wired ethernet to the same switch. I can confirm that the Mac mini has no difficulty accessing the music library on the NAS as it merrily indexes the share when the server is started.

BTW: The interesting thing is that if I start Roon on the Mac mini and attempt to play to an endpoint, I can get it to work once after a several minute delay. Seems that Roon has tried to communicate with something network-wise that does not resolve and it is waiting for a TCP timeout or some such? Wild guess here: since OpenDNS & curate their DNS entries (so that they are a subset of usual DNS), I wonder if something Roon-related isn’t resolving or has an long TTL that points at an old/invalid IP address?

After trying a bunch of other network and system trouble shooting things, I decided it was time to take the drastic step of replacing my seemingly working current Roon database with one from late last year. Sure enough that fixed the problem! So, it seems that Roon had corrupted its database AGAIN!!! Yes, this is the third database corruption I’ve had to deal with in as many years. And, it’s not sever specific beacuse I’ve experienced Roon database corruption on two different sever hardware setups.

@Daniel Thanks for your help, however, it would be great if you can let the developers know that this Roon’s penchant for corrupting its own database is something that needs to be addressed at the software architecture level. Whatever database technology you are using for the library is simply too unreliable for a consumer product. See the I would assume that Roon is using the latest DB technology - #40 by xxx thread for others who feel the same.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hi @The_Leisurely_Loris,
I know it’s a bit of a long shot but do you by any chance have old logs from these previous corruptions? If you do please upload using the directions found here and send over a set of logs to our File Uploader?

This topic was automatically closed after 11 days. New replies are no longer allowed.