Roon won't play mono FLAC created from ffmpeg

You guys may think this is trivial, but it seems like Roon should play it. I generated a series of test tones using ffmpeg. Media Monkey and other software plays them but Roon won’t. Here’s an example:

ffmpeg -f lavfi -i “sine=frequency=1000:duration=60” 1000Hz.flac

The only thing I can see that is “wrong” is that it generates only one channel. However! When Roon plays it I see “Channel Mapping Mono to 2.0” so it seems like it is trying to make it work but failing.

I am using Ubuntu 20.04.2 LTS to generate the tones.

This isn’t a huge issue for me, I am going to create actual stereo files to work around.

Hello @Erik_Squires , do you have convolution enabled? See

It’s an old thread, but it appears it is still open.

Bug present since Roon has a DSP.
Still unsolved

1 Like

Oh, this sounds like it could be related.

I have procedural EQ’s with parametric filters. I like to set my EQ by hand though. I’m in the Floyd Toole school of EQ: a careful gentle hand should be used when setting EQ filters.

Hi @Erik_Squires — I checked our internal tracker and it looks like this is still an open ticket in our system. I’m going to bring this up in our next meeting to see if there’s anything we can change here.

Just so we have a more recent example for the team to work with, would you share screenshots of your DSP settings and send this file to me in a PM via shared dropbox link (or any other file sharing service)? I’ll pass it along to the team.

2 Likes

Hey Dylan,

If you mean this, then sure see below. :slight_smile: If there’s anything else, please let me know.

If you want a sample FLAC file I generated they are < 1 Mbyte so it’s pretty easy to e-mail.