Roon won't play Qobuz through Sonos speakers

Core Machine (Operating system/System info/Roon build number)

Rock running on Intel NUC i3
Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

NUC is hardwired through switch on Gigabit network
Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonos speakers wireless to the Sonos hub on the network
Description Of Issue

Roon plays my local library from my Synology NAS just fine through the Sonos speakers. Roon also plays fine from the NUC via USB directly to my Schitt Audio DAC to the main audio system. But when I try to stream Qobuz using the Roon app to my Sonos speakers, it tries, I get a few seconds of audio, but then pauses and just keeps trying but I never get a song to play.

Hi @Rex_Noel,

If you go to Settings > Services and lower the streaming quality of Qobuz (just as a test) is there any change here?

Dylan, that worked, thanks. Had to go to CD quality, nothing higher. I had read somewhere that Sonos could only handle that level, not HD. But I assumed Roon would automatically adjust the stream for Sonos. The problem here is that I don’t want to have to go with the lower quality on my main audio system when HD is available from Qobuz. And it’s a pain to have to change that setting every time.

Hi Rex,

As an FYI, DSP is per Zone Output, so you can set Qobuz to HD. And then in the Sonos zone, under DSP, set a custom sample rate conversion for the Sonos zones so that Roon downsamples everything 44.1.

Thanks Daniel,
That sounds like what I’ve read, but I’m having trouble implementing. I’m only on my second day with Roon. I went to Services/Qobuz and reset it to HD. After that, I’m not sure how to set DSP or how to find a zone. What I have tried is to go to Settings/Audio, which gives me the list of connected devices. On one of my Sonos speakers, I clicked on the gear icon and Device Setup, then Show Advanced. Only one item there and it already is set to Downmix as needed. That sounds like it should automatically downsample to 44.1, but it apparently is not.

Well, with the Sonos speaker selected as output, click on the speaker icon, which will bring up a menu that has DSP.

When you open the DSP page, make sure that Sample Rate Conversion is Enabled. If not, then enable it and test it.

If it still doesn’t work, go back to DSP, keep Sample Rate conversion enable, and change the drop down from For Compatibility Only to Custom. And then for each input resolution on the left, change the output resolution to 44.1 (or 48 or whatever you want).

Many thanks for the detail. The Sample Rate Conversion appears to work on a quick test on one speaker. I’ll change them all and give it a better test. For what it’s worth, I don’t see a drop down with the For Compatibility Only/Custom choices, at least on my phone app. I’ll look further for it. Anyway, looks like you have me going.

Desktop App I think. The phone app does not have all the settings options.

Worked on the iPad this morning. I’ll give it all a better test today. Thanks for your help

1 Like

Hi @Rex_Noel,

This is correct, it should re-sample to the maximum rate your device supports, strange that you’re saying this is not happening here.

Are you saying that re-sampling to 44.1k works but 48k does not work?

This should happen by default in my experience with Sonos devices. Maybe a setting got changed, but i don’t think you should have to set up manual Downsampling in DSP.

I’ve been testing Roon with Qobuz and my local library today on my 7 Sonos speakers. Per the discussion above, I’ve adjusted the DSP setting to 44.1 for all of them. I still get frequent dropouts during albums and playlists. I’ve compared to Qobuz through the Sonos app and it plays flawlessly. So something about the Roon software relationship to my Sonos speakers just isn’t right. I assumed as described above that downsampling to the Sonos capability would be automatic, and it wasn’t. After adjusting the DSP settings it is better, but still not all that good.

Resampling to 44.1 works, sort of, but not 48. Extensive testing yesterday found some albums from Qobuz would stream ok for some period of time, but certain tracks would fail. In other cases, Qobuz radio would go fine for a while then stop. Nothing I tried from Qobuz would be stable for very long on any of my Sonos speakers. I can’t discern a difference between older gen Sonos and the latest generation.

1 Like

Hi @Rex_Noel,

Thank you for those additional details, hope you’ve been well during this holiday period!

I would like to suggest a troubleshooting step here, can you please try to perform a ROCK OS reinstall via the Web UI and see if that helps?

If the reinstall doesn’t help, can you let me know the exact local time + date + track you next have an issue with?

Thanks noris. I did the reinstall, been playing on Sonos for about 2 hours now. I’ve tried a couple different groupings and so far so good. I’ll be playing with it more today and will come back to you if I have any dropouts.

I’m very curious why the reinstall would correct the problem?

I played Roon Radio through several Sonos speakers throughout the afternoon, probably 3 hours, without any dropouts. About 1600 local I started a Qobuz playlist, and the first two tracks played fine. Throughout, I still had Qobuz set to 16/44.1 per the earlier suggestion here. During that second track, I thought I’d try setting it back to 24/192. About half a track later, at about 1608 local EST, it stopped playing (track 3 Chitlins con Carne on Hi-Res Masters: Jazz Guitar playlist). I tried to restart it, got a few seconds then stopped again, same behavior as yesterday. I then set Qobuz back to 16/44.1 and restarted the track and the playlist has been fine for about 35 minutes now. That is fine for Sonos, where the max is 16/44.1 anyway. But it will be a pain to remember and reset the Qobuz resolution for my main audio system every time.

1 Like

Hi @Rex_Noel,

Thanks for those additional details and Happy New Year!

What is your internet speed according to or
It sounds like there might be a bandwidth issue here.

What kind of switch, managed or unmanaged?
What is the model/manufacturer of the router?

Fast reported 44Mbps down, speedtest 48 down, 5.4 up. Router is a Leviton branded router in one of their structured wiring boxes. The switch is Leviton also, in the same panel, don’t know if managed or not.

I don’t have any issues streaming 4K video on the same network, wired to one TV, wireless to another, so bandwidth hasn’t been a problem otherwise.

As a thought when playing to the Sonos devices what’s the processing speed showing in the signal path. Just wondering if that’s the issue. If its lower than 1 then this could be the issue and when it’s applying downsampling which it will do automatically for non supported formats or if you set it it may drop more. It may not be this but worth checking.

Right now playing a Qobuz playlist to two Sonos speakers, working ok. Processing speed is 57.7. Several conversion steps, bit then sample rate then bit again, looks like it ends up 16/48. Seems to be working okay this morning.

1 Like