Roon Won't Play Tracks

Help - @support

Strange issue - I copied a new album to my Roon library. The album has three discs. Disc one has 15 tracks. For some reason, tracks 14 and 15 on Disc one won’t play. When track 13 is over, Roon skips track 14, goes to track 15, and just stays there and won’t play. If I click on the Play icon on the left side of Track 14 or 15, they don’t play. But strangely, I can click on the Play icon to the right of the time of Track 14 and select “Play Now” and it will play. This works for Track 14, but not Track 15.

The issue is the same regardless of which output I am using, e.g. my Mac, the UltraRendu/Brooklyn, or any of my Sonos. It is also the same regardless of which controller I am using, e.g. my Mac, iPhone, iPad, etc.

These are 24/192k FLAC files, and they are fine - they aren’t corrupt - they play fine in VLC and other players. Roon analyzed them, no problem.

I have tried re-scanning, re-analyzing, and even deleting and re-copying them. I even changed the album title in the metadata of the files to import them as a different album, and still the same issue.

I run Roon on a SonicTransporter i5 with the files on a USB attached hard drive.

I have also rebooted the SonicTransporter, stopped and restarted the Roon server, cleared the Roon cache, etc. Still won’t play those two tracks.

Which album and which tracks?

Bruce Springsteen and The E Street Band, London '81, download from yesterday.

Disc 1, tracks 14 and 15 - Badlands and Thunder Road.

which format version? regular CD, DSD, HiDef FLAC?

@Rugby See first post

1 Like

I just downloaded the same and the files have issues.

I converted those two files to the same format and Track 14 began working as expected. Track 15 still had the same issue. I then converted Track 15 to FLAC and the FLAC version also had the same issue. still working.

Strange - I have no issue playing these tracks in Audirvana or VLC… I downloaded the 24/192k FLACs from I converted them to ALAC and copied them to my Roon library, same result.

Okay, after snooping around the logs and transcoding the file to WAV, removing the tags, MP3 and downsampling it to 24/96. The MP3 and the 24/96 downsample works; i.e. plays in Roon. When the original file plays; Roon seems to be seeing it as an MQA stream and not playing because 24/192 is causing an error -

Critical: threadpoolsynchronizationcontext: System.ArgumentException: MQA decoder does 1x->2x but got sample rate 192000

Which both makes me curious and annoyed with the provider and not really able to trust the source.

Aha… I see the same error in my logs. Yes - annoying that they screwed this up. I am going to send a message to nugs…

Let me know how that resolves as I’d like to get a replacement file as well. Meanwhile, I can live with the re-sample to 24/96. And I will also send a message to nugs.

I was about to write in with the exact same problem. I have the tracks in 192/24 FLAC and they won’t play in Roon. Interestingly, they work fine with my JRiver Media player. Not really sure I understand your explanation especially the MP3 part. I have a converter, can I just downsample the flac file to 24/96?

Yes that is what I had to do. Convert the file to 24/96.

Hi. I know this is an old post but I found it because I have the exact same problem. I have just bought an album from Linn Records, 25 tracks FLAC 24 bit 192 kHz. Tracks 1-19 play flawlessly but then Roon skips track 20 and freezes on track 21. After I found this thread I checked the logs and same, Roon seems to expect MQA. I contacted Linn and they have no idea why this is happening. Converting the files to 96 kHz solves the problem.

A post was merged into an existing topic: Not playing tracks