Roon won't run in a window on a 13" screen?

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Just set up a new Dell XPS 13 laptop and found Roon doesn’t want to run in a window unless I reduce the screen “scale” from the recommended 150% to 125%. At 150% I get a message saying “Your screen resolution is too small to run Roon. Please try to run maximized or full screen.” Maximized doesn’t work, so full screen is the only alternative, which makes it inconvenient to switch from Roon to other apps.

The display resolution of this computer is 1920 x 1080, which seems like it ought to be enough to run Roon if I can also run it successfully on an Android phone and an old iPad.

Sure hope there’s a “resolution” for this problem. Hard to believe I’m the only one trying to run Roon on a 13" screen.

According to this KB article Roon requires a resolution of at least 1280x720. I would have thought that scaling a 1920 x 1080 display to 150% would give you enough pixels, but clearly not. The KB article I linked shows you how to alter the scale factor for Roon without needing to change your screen scale.

1 Like

The resolution of the Dell XPS 13 is 3840 x 2160 this makes the text really small even though the the screen is 1080P forcing users to change the scaling to make it readable.

You could try changing the resolution in the graphics card settings rather than using windows scaling the result is virtually the same.

or as @DaveN has said try the solution in KB article and change the scaling for Roon from the command prompt.

1 Like

What are the other command-line parameters that can be passed to Roon, anyone know?

I’ve had display issues on my HP Spectre 360. A couple things to try (possibly in combination):

  1. If your window is Maximized, change it to Resize, then adjust the window to fill up the entire available space so it’s functionally the same as Maximized. For some weird reason, this seems to work with certain screen resolutions.

  2. Go to the directory “This PC > Windows (C) > Users > (your user name) > AppData > Local > Roon > Application”, select “Roon.exe”, right-click and select “Properties”.

  3. Click on the “Compatibility” tab and select “Change High DPI settings”. Then check the box for “Override High DPI scaling behavior” and click “OK”.

This solved the problem for me. The text in the Roon remote app isn’t quite as sharp as before, but it’s a lot better than reducing the scale and making text in all other apps in Windows too small.

In general, Roon Remote seems very finicky about the Windows display configuration on my three computers. I have to mess around a bit on each of them to get a workable Roon display. I don’t have this issue with any other Windows applications, so I assume Roon is less than diligent about complying with Windows API.

See picture below for changing the compatibility setting that is described above.

1 Like

Thanks for this. Dragging the Roon window out to full screen didn’t help. The path in your second item

(“This PC > Windows (C) > Users > (your user name) > AppData > Local > Roon > Application”) doesn’t exist on my computer.

I do have:

“This PC > Users > (your user name) > AppData > Local > Roon > Application”.

But when I right-click on the Roon.exe file, I don’t find a “Compatibility” tab, as shown below. I’m running Windows 11 Home.

Unless I’m missing something in your post, the Compatibility tab is right next to the General tab at the top of the dialog box you screen-grabbed.

1 Like

Whoops, I’m embarrassed. The tab is indeed there. I tried it, but even after a reboot Roon still only wants to run full-screen.

1 Like

I’m confused. The Roon.exe properties image that you uploaded shows a Compatibility tab right next to the active General tab. If you click on “Compatibility”, then “Change high DPI settings”, then check the box for “Override high DPI scaling behavior” you could test if this solves your Roon display issue.

I’m still running Windows 10, so if I can’t override high DPI scaling behavior in Windows 11 I’ll have a problem on my computer running Roon core. Aside from funky display behavior, Roon would crash when using certain filters for albums in my library. Overriding DPI scaling fixed that.

1 Like

OK, just saw your update. It looks like setting the scale to 1.25 in the command line is the best thing to try. Hopefully the text in Roon won’t be too teeny-tiny.

Right-click your Roon shortcut, right-click “Roon”, click “Properties” and add " -scalefactor=1.25" after the Target path. That should work since setting your screen in Windows settings to 125% worked, but this way the scale is only changed when launching Roon from the shortcut. See below.

1 Like

Yeah, as noted above this is my bad in overlooking it. Still getting used to looking at things in 125% scaling factor.

Anyway, I did find it and tried this, but still cannot run Roon in any format at less than full screen. It does run okay at 125% screen scaling factor but that’s a bit small for my old eys.

Well, you could try changing the Roon shortcut by going down from 1.5 in .05 increments until you don’t need to use full screen. If it works somewhere above 1.25 then maybe the text will be easier to read. Target plus command switch text below:

C:\Users\JohnG\AppData\Local\Roon\Application\Roon.exe -scalefactor=1.45
C:\Users\JohnG\AppData\Local\Roon\Application\Roon.exe -scalefactor=1.40
C:\Users\JohnG\AppData\Local\Roon\Application\Roon.exe -scalefactor=1.35
C:\Users\JohnG\AppData\Local\Roon\Application\Roon.exe -scalefactor=1.30

1 Like

Thanks to all who replied. Here’s what worked: a 1.25 scale factor for Roon and a 150% scale factor for Windows.

C:\Users[username]\AppData\Local\Roon\Application\Roon.exe -scalefactor=1.25


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.