Roon won't stream on my Airplay devices

Roon Core Machine

Roon Nucleus

Networking Gear & Setup Details

iMac and iPads

Connected Audio Devices

Parasound pre-amp connected to Nucleus via HDMI

Number of Tracks in Library

About 1 terabyte, but I’m primarily streaming via Tidal and that’s where this issue is observed

Description of Issue

System was working fine before a few days ago. I appear to be logged in to Tidal and everything there is OK. My Sonos device streams the Tidal content (via Roon) OK, but my Airplay devices (iMac, iPad) in the Roon app show the Audio devices as connected, but when I press play it shows “Nothing playing” or simply doesn’t play (the time bar doesn’t advance). No error message appears. Doesn’t seem to be Wifi network issue, as the Sonos streams via one of the iPads from the Nucleus OK. So specific to the other, non-Sonos devices.

Have you tried to reboot everything in the chain?
Roon Core, Airplay devices, router etc?

Yes, I’ve rebooted all devices and problem persisted.

Are these your Airplay endpoints? Or are other devices used?

I ask because your iMac and iPad are native Roon RAAT and need not use Airplay.

It’d be really helpful if you shared a screenshot of the Settings > Audio page.

Screenshot attached. Some explanation: the items listed under “Connected to Core” are various inputs on the Parasound pre-amp, the one labelled “Parasound” is the one that I had been using successfully, but which now isn’t playing.
I can stream to the “BR Sonos” listed under “Other network devices,” which is what makes me think its something related to Mac or Airplay, since the Sonos device is the only one that’s not having this issue.

Without intending to be pedantic, these are outputs on the Nucleus, and you have renamed one “Parasound”. This is not an Airplay interface; it is ALSA, which means it’s a RAAT connection.

Can you please confirm the type of interface, e.g., USB, and the exact Parasound model. Thanks.

No worries, thanks for clarifying! The Nucleus is connected to the Parasound by a USB connection, and the Parasound is the P6 2.1 channel pre-amp.

Problem has resolved, thanks for all the help! The one thing I did that may have helped was to reboot the Nucleus itself, which I hadn’t done originally (I had rebooted the iMac and iPads and reloaded the Roon application to the iPad). This didn’t fix it immediately, but when I tried it again about 12 hours later it was working. So either that was it (albeit a delayed response to the reboot), or it fixed itself somehow.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.