Roonbridge doesn't see USB DAC

Roon Core Machine

Roon Core 1.8 build 850 running on Intel NUC

Networking Gear & Setup Details

WiFi network - Netgear Orbi RB50

Connected Audio Devices

Beagleboard with with USB DAC Vioelectric connected.
|Distributor ID:|Ubuntu|
|Description:|Ubuntu Xenial Xerus (development branch)|
|Release:|16.04|
|Codename:|xenial|

Number of Tracks in Library

28,000 tracks

Description of Issue

Hi,
I can see my Roon Bridge in Settings/About.

I don't see any devices under Audio for RoonBRidge.

When checking on BeagleBoard I can see RoonBridge active and my USB DAC is a default audio device.
What can I do to make it visible under Settings->Audio in Roon?

Log files for RoonBridge are clean

Hello,
Can someone from Roonlabs support give me a hint what to do next?
Is there some known generic issue about using Beaglebone Black as roon endpoint with Roon Brigde?
I have tested the USB DAC, and it shows up if I connect it directly from Roon Core machine.
Roon Bridge is visible in Settings->About. However no audio devices are visible under Settings->Audio for RoonBridge when same USB DAC is connected.
I have even upgraded to Ubuntu 18.04 on my Beaglebone but the issue is exactly the same. RoonBridge visible, but no audio devices available.
I will be truly thankful for some help.
There is only one audio device connected to my Beaglebone:

Hey, @JSA23 we’re so sorry that it took us time to respond to the issue you’re experiencing - it certainly was not our intention!

We wanted to check in and see if you were still having trouble with this?

Thanks!