RoonBridge gives mscorlib.dll invalid error


I recently re-installed my Rasberry Pi 3 with Rasbian. I am having an awful time trying to get the RoonBridge to work. At first I thought it was my Roon server than runs on a Windows 10 machine, so I messed around with the firewall settings and enabled Roon in Windows Defender.

Unfortunately still no joy. I then went to my RP3 to check the RoonBridge logs to realise they were empty. I then checked running services to see RoonBridge wasn’t even running. I attempted to run the following:


And I get the following error:

The file /opt/RoonBridge/RoonMono/lib/mscorlib.dll is an invalid CIL image
/opt/RoonBridge/ 37: kill: No such process

When I run: /opt/RoonBridge/ it says everything is ok with a status: success.

My soundcard is present (HifiBerry DIGI+) so I have no idea what is going on.

My rasbian version is

`Linux raspberrypi 4.14.30-v7+ #1102`

And the RoonBridge version I ran was 100000167 1.0 (build 167) stable

Can someone help?


Is this purely to run RoonBridge? If it is, run Ropieee instead of Rasbian. It has RoonBrridge integrated and its author can support any issues you may have from these pages.

I agree with the recommendation to try Ropieee. It’s much more turnkey. DietPi is another option that makes it very easy to get going with Roon Bridge.

That error message on Raspbian indicates that your install is corrupt. Maybe the SD card is full and that file got truncated (I think raspbian has a resizing step that you’re supposed to do after OS install–possible that was missed?). If there is ample free space, you could try installing Roon Bridge again…but really, I would use one of the above distributions that has Roon Bridge supported out of the box.

Thanks for advice, will give it a go. Although I am running a TPLink Wi-fi dongle from the RP3 and getting supported drivers for this is a nightmare, but I managed to get them for my Raspbian install. I’m sure I had RoonBridge working on this before.

I didn’t do the resizing step after install, perhaps that has something to do with it. In any case I’ll start again as it sounds like something fundamental has gone wrong.