RoonBridge on Olimex a20: change settings in Roon requires reboot [Solved]

I installed RoonBridge on an Olimex a20 card using the installation procedure. The device appears as an audio output but no sample rates are available. When I reboot, the sample rates are all green but the first time I play something I get an error message “transport error” and the device then appears as “not found” in the audio output settings. In the “Playback settings”, no sample rates are available (“This device does not appear to support stereo playback at any sampling rate…”).

When I launch the script everything is OK.

Playback on the same card using Squeezelite still works…

EDIT: started working after another reboot. Everytime I change the settings, however, I get the same problem again and need to reboot.

Am running ArchLinux 4.5.0-2

Unfortunately, we don’t have one of those so it wasn’t part of our testing prior to release. That said, we do have a RoonReady hardware partner that uses Arch on an A20 so we know that the core RAAT code is alright there.

RoonBridge requires exclusive access to the audio device, and sometimes if other software is using the device when we try to access it, you can see behavior like this. Is there any chance you have other software running on the A20 that is accessing the audio device?

I disabled squeezelite and shairport and it seems to be working fine. Thanks !
Good call on supporting Allwinner A20, btw…

Glad to hear it was that simple…I was thinking about what I’d have you check next :slight_smile:

I should have tried that immediately myself…

Hi Stephane,

Great to read that you got ROON Bridge working on the Olimex Lime2 board
I am curious how it is preforming, does it work good? (also with High Resolution PCM 24bit 192 kHz files?)
I was wondering if you would sent me the image you have created, I’m not so experienced with Linux command line
If you could help me with installing ROON Bridge on the Olimex, I would be very grateful!

You can contact me at:
Thanks in advance, Maarten

Hi, I am. Sorry but I have not kept the image I made a long time ago and I switched to dietpi on a RaspberryPi à long time ago as well. Afraid I cannot be of much help.