RoonBridge on Volumio Raspberry Pi Image?

Have you tried:

sudo apt-get update && sudo apt-get install systemd

You could also try:

sudo apt-get dist-upgrade

See this thread on the Volumio forums

Sadly much the same still…I posted in the link on Volumio forum now too - I think its just the bzip2 that needs to be installed but that alone causes a similar error message.

volumio@volumio:~$ sudo apt-get update && sudo apt-get install systemd
Hit jessie InRelease       
Hit jessie/main Sources    
Hit jessie/contrib Sources
Hit jessie/non-free Sources
Hit jessie/main armhf Packages
Hit jessie/contrib armhf Packages
Hit jessie/non-free armhf Packages
Ign jessie/contrib Translation-en
Ign jessie/main Translation-en
Ign jessie/non-free Translation-en
Reading package lists... Done                                                                                                                
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 systemd-sysv : Depends: systemd (= 215-17+deb8u5) but 215-17+deb8u6 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
volumio@volumio:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libpam-systemd : Depends: systemd (= 215-17+deb8u6) but 215-17+deb8u5 is installed
 systemd : Depends: libsystemd0 (= 215-17+deb8u5) but 215-17+deb8u6 is installed
E: Unmet dependencies. Try using -f.

I don’t use Volumio anymore. I’m now using Mopidy. It’s more work to set up, but it’s also far more flexible (here is a blog post how I set it up).

If you don’t want the hassle of installing Mopidy you could also try Rune Audio. It shares some similarities with Volumio (both originate from the same project I believe).

Thanks Julius, Ill check those out. I want something stand alone for demo’s on the road but operable with Roon when Im at home :stuck_out_tongue:


for whatever reason I have no idea the exact same commands today work perfectly and I can install Roon Bridge under Volumio again - must have been something messed up in the repositories

This time all that was needed is as follows

sudo apt-get update
sudo apt-get install bzip2
curl -O
chmod +x
sudo ./

I hate computers sometimes :triumph:


I’ve added a 7" LCD display and case from element 14 to the volumio/roon bridge setup with some case mods…pretty happy so far managing to squeeze the IQAudIO DigiAMP+ in there too with some degree of success. I’ll do a build log sometime soon too


Great wizard I am new to Volumio and diet pi
I see you have mastered the dark art of loading Roon Bridge to Volumio
Is there any chance I could get some guidance starting from

  1. switch on monitor.
  2. Start raspberry pi
    3… oh god someone speak English to me this is killing me :weary:

Perhaps someone will get you to the ssh stage but I’m not able to do so at this time sorry. The rest is posted above

all good!
it worked!
followed the command lines above


FYI now both my setups are using Ropieee as I am happy with just Roon as a source.

I need a distro for Raspberry Pi B+ (gen 1, V1.2) without a HAT installed to just run as an endpoint for Roon with ethernet in and USB out. Ropieee does not run on this old model. Could I use Volumio, with or without Bridge, or any other «standard» distro?

I’d suggest Ropieee. It’s more stable than Volumio and it comes ready to go with Roon support, in fact, that is all it does.

So Ropiee does run on Pi B+ generation 1, V1.2 and not only 2 and 3? I have one unsuccessful install, but with a 32GB card. Ropiee recommends 4 or 8 GB.

I missed the generation. Harry @spockfish would have to comment on whether you can use it in the early generation.

You can Install RoonBridge on Volumio. I have this setup in my kitchen. But you need to Install RoonBridge manually from command line (afaik).

Unfortunately the Generation 1 won’t work for that, as RoonBridge is not available for that architecture (it uses a ARM1176JZF-S cpu and only supports ARMv6). RoonBridge requires ARMv7 or ARMv8, which is used on the Raspberry Pi 2 and/or later.

You could use your Pi still with volumio and use Airplay as the audio protocol…

1 Like

Thanks. I have enough AirPlay/Sonos endpoints, so I guess I´m finding another project for the old’Berry and buy a 3 for Bridge or Ropieee.