RoonBrige Problems on Linux

Roon Core Machine

1.8 (build 831) stable (64bit)

Networking Gear & Setup Details

ASUS RT-AC66U B1 wired only

Connected Audio Devices

Setting up RoonBridge manually on a Gentoo Linux box

Number of Tracks in Library


Description of Issue

So I’ve made some progress from the last time:

This time, it is running and I can see the audio devices in the settings; however, I cannot enable. All I get is an “Enabling…” message and when I try to name it and press enter or click out of the text box the Roon Player crashes. I can reopen with no harm done but it still says “Enabling…”.


I had a similar problem in the past.

Roon is partly server based and when the connection to the server or the server is temporarily overloaded, there are such problems at times.

The easiest thing to solve such problems is often a restart of the Roon server (core), but of course not always.

I just tried it. It made no difference.

I was wondering if maybe it’s a local port that needs to be open. I try to close my ports as a rule but I was going to try opening them and see if that changes anything.

Ok so it is my firewall! I use shorewall as my firewall configurator so I completely disabled it and RoonBridge works. The problem now is that I still want to continue using shorewall (for security purposes). So what ports do I enable to get RoonBridge playing nicely with shorewall?

Currently I’ve enabled the standard ports along with some extras I found on the forums here:

TCP Ports

  • 9100:9200
  • 49863
  • 52667
  • 52709
  • 63098:63100

UDP Port:

  • 9003

But enabling these ports doesn’t help. Any other suggestions?

I think you must do specific configurations on Shorewall for allowing multicast traffic. A quick search on Google should bring up examples to guide you.

So, I’ve enabled multicast in my firewall as well as the respective ports but I’m still getting nothing. I wonder if multicast is a red herring… Anything else I can try?