ROON's TIDAL Browse function shows "Error loading page" at start-up

Core Machine (Operating system/System info/Roon build number)

Roon ROCK( Version 1.7 Build 537) running on a NUC8i7 BEH2 with Crucial CT8G4FSS8266 8GB DDR4, 2666MT/s PC4-21300 Single rank SODIMM 260-pin and a Transcend SSD, 3d and Flash-Chip 128GB.

Internal storage on a Crucial MX500 2.5-Inch SSD.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ROON ROCK is hard wired via Ethernet cable to my ISP router (Arcaydian V10A).

ROON Remote on both an i-Pad and an i-Phone.

Network is a roaming network with 2 Apple Extreme’s and an Apple Time Machine, all operating in bridge-mode.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

RME-ADI-2 DAC connected directly to NUC8i7 via USB.

Description Of Issue
Gentlemen, Ladies,

This is my first post on the board and I am sorry to start with a problem.

Ever since the last three updates it is becoming increasingly difficult to browse TIDAL via ROON Remote.

After starting the ROON app on either my i-Pad or i-Phone it takes a long time for content like “What’s New”, “Tidal Rising”, and especially “Genres” to load and every time the message “error loading page”, “please check your network” comes up.
When the ROON app is awaken from sleep mode it is impossible to access TIDAL and the only thing that helps is shutting down the app and restart it again.

Accessing my TIDAL app directly without ROON does not show any problem at all. Furthermore, there are no other network problems in my WiFi configuration, that I know off.

I have tried to re-install the roon app, the roon operating system and a factory reset of my router, all to no avail.

Could you please help me in finding and solving the problem? I like ROON very much and would like it to work flawlessly again like it did before.

Many thanks in advance.

Hi @Gustaaf_van_Veelen, and welcome to the forums!

Our team is currently investigating an issue that affects some Roon users that can result in being logged out of TIDAL when Roon is launched. We have a ticket open with our development team and we hope to have an improvement available soon. We’ll be sure to keep you updated.

Hi Dylan, thank you very much for your reply.

Hi, I have exactly the same problem, it seems to drop out for both Tidal and Quboz - would be an internet issue?

Hi Daniel,

Sorry to hear you have the same problem. Could very well be an internet problem. My knowledge of networks and WiFi is basic at best. The other thing I was thinking of, is that it is an operating system related problem. I wonder if it is an IOS specific problem and that a Windows, Linux or Android based operating environment is less affected.
Let us hope the technical team finds a solution any time soon.

1 Like

Regrettable, with the latest update of Roon server software build 555 the problem persists.

Hi @Gustaaf_van_Veelen,

Build 555 included only one small change to resolve a separate issue, but our team is still hard at work on developing and testing the solution to this problem. We hope to have it available in the near future!

Hi Dylan,

Thank you very much for your answer. As additional information I can report that closing the app and restarting it helps in forcing Tidal to show content.

Hello @Gustaaf_van_Veelen,

I wanted to reach out and let you know that we released Roon 1.7 Build 571, which includes some improvements that we believe should help here. Please give the update a try and let us know if it helps!

You can read the full release notes here:

Roon Support

Hello Nuwriy,

Thank you very much for your reply. All problems I have had with browsing in TIDAL via Roon remote have been solved. Great! It all works magnificently again, like it did a couple of updates ago.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.