RoonServer cannot connect over Internet. Help! [Solved]

Recently my MOCK started having trouble that I concluded must be my network. Since that time I did find and resolve one small network problem that was likely unrelated. And I’ve completely re-IP’d everything to help ensure there are no network address conflicts. And every device on my network (roughly 25 of them) works as expected EXCEPT the problems with my MOCK persist. Specifically…

  • It can’t log in to Tidal (yes, I changed my Tidal password just in case).
  • It’s can’t check for an update - says “There was an error checking for an update” in Win64 Roon.
  • It cannot perform a reinstall from the ROCK webpage Reinstall button. Says “There was an error downloading Roon. Please check your Internet connection. {“status”:“Failure”:“exitcode”:10}”

And here’s the kicker… I manually reinstalled ROCK from scratch, the stable version. And all of the same problems persist. I’ve moved the MOCK itself such that it’s hanging off the router that connects to my cable modem, and thus the Internet. There should be NO connectivity issues. Go figure.

Anyone have ANY idea what could be causing this? Is there any way this could be due to ROCK being installed on my "unsupported’ 4th Generation Core i5 NUC? Not sure why what used to work would stop now, but something’s up.


Found it!

When sorting through my network, and re-IP’ing everything, I decided to use static IP’s for all of my network devices, and appliances, like ROCK. And that was the problem!

I had neglected to put my router in as the DNS server. I left that field blank. Granted, that’s typically what’s done when your router is actually just a gateway to DNS. But that’s what made the difference. Sorry to bother you. And GLAD to get this working!

1 Like

I had slow connections to ROCK and it was similarly missing the router IP address in the DNS settings

Actually, in retrospect, the fact that EVERYTHING worked EXCEPT that my MOCK could not get out to the Internet, I should have been thinking about DNS…

Well, another day, another adventure. :wink: