Roonserver.exe immediately crashes (Windows)

Hi,

I don’t know if there is another way to check wich version you have.

This is what i found in the Help section.

Version of Roon

Maarten.

What version of .net are you running. If it is not the latest, then I’d upgrade to it and see if that helps.

Fellow user here.

That’s the latest that MS is pushing automatically though WIndows update. I have it on all my computers.

I just found that the version is listed in a file in the install directory. I’m running:

1008009701.8 (build 970) stablestable

And it looks like it installed on 6/13. The last time I was able to use Roon was 6/12 so I don’t think that’s a coincidence.

Just because it might matter, it was Microsoft patch day “in the last 24 hours or so”.

Definitely a possibility. Hopefully the stack trace in event viewer points the devs in the right direction of whatever is causing this.

Exception Info: System.TypeLoadException
at Sooloos.App.InitPing()
at Sooloos.App.Init()
at Sooloos.App.Main(System.String[])

As it might be caused by Microsoft and it’s automatic updates, it would be helpful if you could provide a list of the updates installed yesterday. I don’t think that the devs are of much help for you as the error looks like a typical .NET error (.NET is a prerequisite for Roon to run correctly, but not provided by Roon) – you may just get the tip to check or reinstall .NET.

Note: Check that .NET 3.5 is installed, this was the last known Microsoft update issue.

AFAIK there is no need to check WCF also.

1 Like

6 posts were split to a new topic: RoonServer is crashing on startup

Here are some screenshots.

  1. No .NET 3.5, I have 4.6
  2. The error started on 6/13 at 11:15 PM (first occurrence)
  3. Windows did update on 6/14, but that’s after the error started
  4. It was working fine on 6/12 (I was using it).

Hope this helps



Looking at the link given in step 5, it looks to me like .NET 4,8 is needed. You may want to try and install it.

Actually, I think you nailed it - I missed a hint in your screenshot.

Your screeny says that .Net 3.5 should be enabled.

No idea why this didn’t impact me before, but I went and checked .Net 3.5, installed it and was able to successfully get roonserver started again.

Thanks BlackJack

Is there a reason why you don’t have .net Desktop Runtime v6.0.6 installed?

As it isn’t a development system, the goal is to have as few runtimes installed as necessary to keep things simple. In this case, the problem wasn’t solved by a newer runtime… I actually had to install an older runtime (3.5) than what was already on the system (4.6).

Understood, I remember reading about roon performance improvements with .net 6.

Interesting, may be worth the upgrade if it impacts Roon Server (I primarily use IOS for Roon clients). I’ll need to poke around the forums to look into that. Thanks for the heads up.

Unfortunately already running the latest .NET framework over here. Also getting the same results, roonserver.exe immediately crashing after trying to start the executable.

Only difference with Stan’s installation is I’m using a Windows 11 desktop as the Roon Server instance. Also tried reinstalling the roonserver btw, but to no avail.

FYI, just downloaded and installed the new Roonserver.exe from Roon, this seems to have solved the issue here :slight_smile:

I am having this issue on Server 2019. .NET 3.5 and 4.7 are installed already.

Looking at the link given in step 5, it looks to me like .NET 4,8 is needed. You may want to try and install it.

Going methodically through all the steps outlined in the guide seems to be a good idea. Most people were able to resolve their issue that way.

I have been having the same error on Windows 10 with .NET 4.8 and no .NET 3.5.

All I did to fix it was reinstall RoonServer. Seems to have sorted it out.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.