RoonServer on ROCK - trouble with SMB: invalid network path

when entering IP address and shared folder comes “Unexpected error”
I really do not know what else to do. When the Core ran on my PC everything was easy.
Somewhere in the rock software must be a mistake. I have now disconnected the core from Rock and relocated it to my PC. a shared network drive per \ PCNAME \ folder was detected immediately. I am sad that my NUC-Rock is not working properly.

Did you check for smb1 being on?

I just tried adding a network share from my Windows Laptop, does not seem to work if password protection is on. But I also could not connect via my phone or any other non windows machine. So i would say this is windows issue not sharing with non windows machines not ROCK and some password encryption issue. I never really use shared folders on my PC TBH. Turning off password protection worked fine.

Should smb1 be active or inactive in Windows? I deactivated it now via powershell.
The network folders do not have password protection. And the error is, I think, no Windows error, on my iphone, the folder setting was not synonymous, now everything goes, but unfortunately not on the Rock Nuc.

Well I’m stumped… @carl or @Rugby can we move this thread to support?

Just want to verify the current situation:
You have a roon installation on Windows and you are trying to setup a ROCK installation. Your files have always been on the WD MyCloud NAS. Windows sees and can connect to the NAS storage folders. The new ROCK is having issues setting up the storage folder on the NAS.

Hi Crystal! It already is in support. But, I’d be happy to add a @support

I was a bit confused by the posts, so I just wanted to clarify the situation before recommending anything.

cYES, I have been working with Roon for 2 years on my PC. Now I have an Intel Nuc7i3bnk. There I installed rock. The first time I set up a folder on my NAS as a folder for the music. This folder works. Add more folders will not work. Except those which are subfolders of the NAS folder. Example: Initialized \ nasname \ backup - is ok. I can specify all subfolders as folders, they work. Not working: \ nasname \ audio for example. This is exactly the same with other shared network folders, for example \ mypc \ audio. In my network I can select from all PCs and iphone this. Just not in Roon, if the Rock Nuc is the Core. Once the core is relocated to my PC, all newly added folders will work. Even turning on smb1 on my Windows PC did not succeed.

This setting doesn’t matter if the Core is on ROCK, even though you might be running Roon client on the PC. ROCK runs LInux which can have different syntax than Windows.

Take a read of this Roon FAQ. Take a close look at the bottom section detailing WD MyClouds.'m_having_trouble_setting_up_my_NAS

I have really - I swear it - everything already looked at and tried.
We also like to forget the NAS location. And again, Rock is installed on a separate Intel Nuc, not on the NAS. The NAS is just one of many locations on the network.

So to be clear is it the Nas you can’t mount on the ROCK machine or other network locations on your Windows PC?

I can not seem to express myself clearly enough. I’m talking about at least 3 devices: 1. Intel Nuc computer, Rock is installed there. 2. the NAS with the audio files There is NOT rock installed. 3. a Windows PC.
The NAS (# 2) is connected to the Windows PC (# 3) via network. No problem.
Rock Intel-Nuc (# 1) is connected to Windows (# 3), I see the folder “Data”. If I start the program Roon and want to enter a new location, only one access to the NAS (Nr.2). I installed Rock again on Intel-nuc (# 1). Without a backup. The connection to the NAS (# 2) I managed again with smb: /// IP address / directory. To Windows PC (# 3) I did not succeed. I have tried all possible syntax. With IP address, with network name, with and without smb, doing \ and //. With password, without. Unfortunately, I can not describe it more clearly.
I also do not know why Rock needs to use smb1, it is outdated and uncertain.
If I put the Core back on my Windows PC (# 3), I can easily share shared network folders.

Have you tried restarting you network gear at all and devices. This can sometimes clear things up.

I assume that you have first done the step of explicitly sharing the folders that you want to access on the Windows PC before trying to add them as network folders on the ROCK/NUC? And you will definitely need to use the Windows Credentials (username/password) in the ROCK/NUC network folder details.

It is exactly like that. I also tried to administer with the ROON app via iphone. No success. However, with the app Filebrowser (only as an example) I get access to the network folders from the Windows PC (# 3). Enter name and password - works. In Filebrowser I also got access to the folder Data for Rock (# 1). There I was shown smb2 to rock, the others (PC, NAS) smb3. Should I disable smb1 again?

Hi @Robert_Ostermeyer,

To recap:

  • You recently moved your Core from PC to ROCK and this is when the issue started
  • You can add a watched folder from your NAS without issue
  • You cannot add a watched folder from your PC
  • You’ve enabled SMBv1 on your PC, no change

Is that all correct?

Starting out, I’m hoping you can describe your networking setup for me. How are each of these devices connected to the network and what networking hardware (router, switches, etc.) are in use?

Next, can you share a screenshot of the folder you’re trying to share on the Windows device? Please include a screenshot of the Sharing tab of Properties for this folder, as seen below:

Yes - 4x

I have tried 4 PC with Windows 10 and also an iphone with the app filebrowser. All devices work without problems with network name or IP address and protection username / password with shared network folders. I think the problem is with the software ROCK for NUC! There is probably a problem here with an outdated Samba integration. Why is my NAS working with a linux derivative on all windows machines? Without big changes? Why is the iphone working in the network? Here in the forum there are so many error messages to exactly this problem (unexpectedError)? My solution was:

  1. enable smb1 again in Windows 10 (developer - please add smb2 - better smb3)
  2. increase the IRPStackZize
  3. in the Windows - extended sharing settings - password-protected sharing off
    then I was able to connect with “smb: // ipaddress / folder”.
    Why the mistake came before I can not say. Maybe Rock can not handle usernames that contain a @? This is very common in Windows 10 because it syncs a Windows account.
    It is a solution, but an uncertain and outdated.
    Please developer, makes it possible that a password protection works again in Windows 10, that I do not have to raise an IRPStackSize manually over Regedit and an outdated smb1 protocol is used.
    Although I have an unlimited license, I do not want to wait indefinitely.
1 Like

Your step 2 is not needed AFAIK - I’ve never had to touch this setting in all my years of using Windows and Linux/ROCK.
Your step 3 has succeeded because you’ve turned password-protected sharing off. It appears as though you’ve been using your Microsoft Account (which uses an email address) as the username to access the shared folder on your Windows 10 PC. This often seems not to work properly. Why, I’m not sure.

You could use the name of the local account on your Windows PC instead. Windows 10 installations always set this up and map it to your Microsoft Account.

The local account name is the same as the user folder name. So, for example, if your user folder is at C:\Users\fred - then the local account is fred, and this will be mapped to your Microsoft Account which could be In Roon’s Add Network Share page, you would then use fred and not as the username, and use your Microsoft Account password in the Password field.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.