rooNuimo – best Roon controller ever

Thank you for the possibility to use such a nice gadget with roon. I got my starter kit yesterday, I did all the modifications on the NuimoHub - but it does not work, the hub did not start after plugging it in (no light). The details:

  • the hub worked before changing sd-card and stick (asus bt400)
  • I tried rooExtend 2.0.2 and 2.0.0 NUIMO_HUB, both the same
  • flashing the sd-card with Etcher on my iMac worked fine with 2.0.2, 2.0.0.nuimo_hub produced a checksum error every time I tried (is that the problem???) I used 2 different sd.cards.

I hope you have any suggestions, thank you very much.

Thanks I’m going to try it with a TP Link adapter and will report back with details.

1 Like

Hello Rudolf,
I run the rooExtend_v2.0.0 NUIMO-HUB.zip without any problem in my system. The other image is the one for the Raspeberry Pi and can’t work in the Nuimo Hub.

You need an SD-Card of minimum 8GB for the HUB-image.

Getting errors during programming the SD-Card means something went wrong and the SD-Card is not prepared the way it should.

Please (just to be sure) download the image again and try to copy it in the SD-Card again. If you made that without errors the SD-Card shall work as expected in the Nuimo Hub.

Best DrCWO

Hello and thank you for your reply,
the card was 32GB, so the size was not the problem. I will try again, maybe with a different card or on a different PC.

1 Like

I have ordered a Nuimo Controller :slight_smile: without the hub.
One quick question about the required Raspberry Pi 4 Model B: How much RAM is needed? 2, 4 or 8 GB?
Thanks in advance!

Here’s what @DrCWO said a few months ago when I asked this:

2 Likes

Update:
Flashing on my Mac (MacOS 11.5.1) did not work with BalenaEtcher but with Rasperry Pi Imager. Nuimo Hub works. Thank You!

3 Likes

The Mac is a funny beast :thinking:

1 Like

Thank you; I have not searched in the threads of the other controllers.
@DrCWO maybe a good idea to add this information on your product page, too

1 Like

already added to product page … Dankeschön to @DrCWO

1 Like

I just received my Nuimo but I don’t see any tutorial for actually setting up Nuimo with the controller (hub) for Roon. Is the procedure same as setting MS dial? Any differences. Should I remove the roodial 2.7 extension first?

Fred

There are two tutorials:

  1. rooNuimo - How to use the Nuimo with Roon - YouTube
  2. rooNuimo - How to modify the Nuimo Hub for Roon usage - YouTube
2 Likes

I’ve installed it on a rpi zero with 512mb, and it works fine. Running only rooNuimo though. :+1:

Thanks….couple of things:

  • is there a trial license option available?

  • does upgrading the hub SD card with any future updates require dismantling the hub each time or can it be achieved over the network?

Please can you also send me the link for the latest hub software?….

Hello Jock,
for rooNuimo there is no trial license, sorry.

I offer a trial license is for rooUPnP only, because UPnP has so many different implementations on different devices and this has evaluation makes sense before buying.

Currently upgrading means dismantling. Now as rooExtend has a License Manager I plan to offer an OTA update mechanism for minor releases but not available now.

The latest version for the Nuimo-Hub you can find here:
https://drive.google.com/drive/folders/1c72vVpuuVlIWJpB8flVAZlHXmW2KNd1k?usp=sharing

Best DrCWO

This sounds interesting. DrCWO writes that a RPi 4 is needed to operate a Nuimo Controller without a senic/Nuimo hub. I that case I would prefer a Pi Zero.

Will also do fine. But there will be more future Roon Extensions requiring a Pi4. So maybe it’s a better invest, even now. And please look at the nice cover plates I offer :wink:

rooExtend – The easy start with Roon Extensions - Audio Gear Talk - Roon Labs Community

2 Likes

I can report that I was able to get the Nuimo hub to work with a TP-Link Bluetooth 4.0 Nano USB Adapter UB400 @DrCWO

1 Like

Thank you, I updated the offer in sellcodes.

The Asus BT400 Stick that I use in the moment does not provide a stable connection, no recommendation. I will change it, but its hard to get any. I ordered the GMYLE…