RooPieee device drops, sleep mode.. no conncetion


I am running a roon bridge on an Raspi B+ with RoPieee and it was working fine so far. For some weeks now I got drop outs or the entire Raspi disappears from my roon Audio console and music stops.

Roon is on 1.8 (build 936 stable) on all two iPad controllers and the Mac Mini acting as roon server.
The Mac Mini 6,1 is on macOS Catalina 10.15.7 CPU 2,5 GHz Intel i5, 16 GB RAM

I have reinstalled Raspi by flashing the most recent version via Etcher yesterday on the Micro SD. After installation it looked good , but lost the connection over nicht. In my Unifi console I can still see the Raspi. But if I want to access it via IP or http://ropieee.local/ I can’t reach the Raspi device. It is powered on, the green LED flashed at about 1 Hz as the device now sits on my desk 3m away from the WiFi access point.

The Raspi is a Raspberry Pi 3 Model B Plus Rev 1.3, HiFi Berry DAC+ with Cinch output
The RoPieee version: 2022.04 (0182). The Raspi is connected via Wifi 2,4 GHz now, as my suspicion was that the 5 GHz might cause the problems. But this seems not the issue, but have created 2 WiFi Networks and RasPi goes to the 2,4 GHz.

Anyone who got a similar experience with the Raspi, is this related to a new RoPieee version? For the last 3 years it was running stable.
Anything which might be related to WiFi or network parameters?

Thanks in advance

Have you tried connecting your Pi to your network using ethernet? I’m curious if that might solve the drop outs

1 Like

Yes I was testing it with an ethernet cable connected and it worked, but would need to run a longer test to see if it is really making a difference. I guess it has to do with the WiFi as the device is also not accessibale via the ropieee.local address then.

But anyhow, I was running it on WiFi today also without playing music and it is not visible in roon anymore.

1 Like

I have the same problem with 2 raspberry Pi 3 model B vanishing after a couple of days.
Unplug and reboot solves it for a few days but then they go offline again.

Both worked for several years without problem. Both are wired so wifi no causing it.
@spockfish any idea what can be causing this?

There were probably two issues in my case:

  • The Raspi need to have the exact same name in the router (in case you can edit names there), the RooPiee and in roon. IP is provided by DHCP via the router (FRITZ Box).
  • In the Unifi Clud Key settings I had to disable the "block Multicast LAN to WLAN) for the 2,4 GHz WiFi I created esp. for Raspi and older devices. With the seperate Wifi I could also tell the Raspi to only connect to the 2,4 GhZ WiFi when installing it from scratch.