RoPieee + Audinate Dante USB Compliant device


I’ve been looking at ways to make many of my devices Dante compliant so recently added one of the “Audinate AVIO Dante 2x2 USB Adapter’s” to my collection, this is supposedly a USB Audio compliant device, works in windows & mac without drivers. However RoPieee does not recognize the device even after a reboot.

Wondering if it could receive some TLC and be added to RoPieee.

unique identifier abcac3c87ec5921c

It is being recognized on Linux, but the USB descriptors seem … odd.

It only accepts 48k, with a strange sample format.

I suspect this is the reason RoonBridge does not find a proper setup and why it doesn’t show up.

Quick search on their website also shows exactly a zero match for Linux, so I’m afraid I already know their answer when you ask them for a proper UAC implementation.


Thanks for the speedy reply.

Found this link, but I don’t know if the possible workaround could be implemented in Ropieee

This is not the problem: the device is being recognized by Linux.
It’s RoonBridge that can’t find suitable supported formats, which I suspect the USB descriptor for.


I would personally try the latest Ubuntu server 21.10 version, and install Roon bridge… The latest Kernels seem happier with USB audio devices.

Worth a try

If you try this, please report back.

This is not a kernel problem. And I run a newer kernel than Ubuntu. This is something the Roon team needs to look into.

1 Like

I posted this in the Feature Request thread HERE.

Have you tried fixing the sampling rate in Roon?
Resample everything to 48khz, does this help?

This is the norm for live sound, broadcast and video, which is the primary market for Dante. So not that stange. :slight_smile:

FWIW, I use several of these devices on Android, ChromeOS, Windows and embedded Linux devices. They are also used a lot in live sound on Macs. So I will agree with @spockfish that this is probably something that Roon Bridge is unhappy about.

I think Its just the Dante AVIO USB Modules that operate at 48k, I have 3 other Dante AVIO XLR’s both input & output that operate at 96k

As an experiment I installed Roon Bridge from HERE onto another pi running piCorePlayer 8.1.

Roon detected the adapter as “Dante USB I/O Module” straight away no tweaks needed.

Just confuses me even more now. With respect, I know you said the problem lies with Roon Bridge and that may still be the case but it does appear to be working on other platforms via Roon Bridge.

This is why is suggested Ubuntu.
Well done

I have 4 x Pi running ropieee directly into 4 audinate AVIO usb adapters onto my dante network and all routing is done via my symetrix dsp playing music to 7-8 different buildings and 10-15 different zones.
Using roon web socket as the front end controller and dante as the routing service, it has been super reliable for almost 12 months now.