Ropieee endpoint keeps disappearing

Hi Harry - I cannot figure out why one of my Ropieee endpoints keeps disappearing. It is hardwired via Ethernet. I unplug the RPi 4B and it works for awhile and then just drops off my zone list completely. I have done this twice now with the same result. Only an issue over the last few weeks. Using 4 other RPi 4B’s with Ropieee - none have this issue. What do I need to do to troubleshoot? Thanks very much. Bob

I would start be going to the WebUi for RoPieee and sending feedback from the “Advanced” tab for the unit with issues, probably best to wait until it disappears again and then send it right away after you reboot it. @spockfish (Harry) may have more to ask but that would probably be what he would need to troubleshoot.

He may need more info on the network set-up? (router, switches, etc.) Is there a Hat on the Pi with issues? Any chance of trying a different power supply with it? Maybe one form one of your other Pis that has not issues? see if it follows the power supply?

Thanks - I will do that…

Harry - just sent info from advanced tab as suggested by bearFNF - 459ee204b2ee39d5. The problem node is sewing-studio. Thanks for the help as always.


Hi Bob,

Your on an ‘ancient’ version: 2022.11.2. I suggest you update first to the latest version.


OK thanks… I will do that.

Harry - I would humbly ask you to look at my situation again, please. Now I have two nodes that will not work. I have spent hours doing updates. I have also resent info - c736939cf73cddb2. These nodes will not work, regardless of how many times I re-boot. “Sewing-studio” and “Office-speakers” are the issue. I have done the updates. Any ideas? Thanks, Bob

And all your units are still not on the latest one :wink:
Is there a reason why your units are not up to date?
I see you reinstalled. That’s not necessary of course, just hit the update button in the webpage.

That being said:

The “sewing-studio” is also not reachable (timeouts) for “Kitchen” (this feedback), so I’m thinking this is a network issue.

So please:

  • update all your units
  • send me feedback from the Sewing-Studio unit


OK - thanks for the quick response. I will attempt to do this. I keep re-booting the “sewing-studio”, but it keeps disappearing - I haven’t been able to get it updated. Bob

Can you explain what you mean with this?

This node keeps disappearing from my network. It is on wired ethernet, so it is not a wireless issue. I have unplugged and plugged it back in at least 5 times now.

Ok, but you can’t reach the web interface and hit the update button?

Nope. Can’t reach it at all. I have sent info on sewing-studio - 15aff510ecbf6449. I have 3 of 4 nodes (including sewing-studio) working now. At this point my kitchen node will not show up in Roon or Ropieee.local. THanks again for looking at this. Bob

Now the sewing-studio doesn’t show up again. I am exasperated. I may dump Ropieee - I have loved using it for the past several years, but I am not going to put up with this nonsense. All 4 of my nodes have IP addresses (1st IP for Office Speakers is Airplay), but only 2 show up consistently. Now it’s only office and living room. And I keep getting new upgrade notices - one node has had about 6 already. What gives???


What heppens if you physically move the sewing-studio Pi to another network jack, like the one you know is working for Office Speakers? If you can reach it there, you may just have a bad network hardware connection of CAT cable issue in the Sewing Studio?

Hi Andrew - thanks for that thought, but I have already done this for ALL FOUR of the nodes today. Maybe I just need to start from scratch and re-burn all the microSD cards. I really don’t have time for that though. What a PIA.

Well, I certainly wouldn’t do that for the devices that are working and have been updated. If you haven’t tried this, it may work. If you have been using a Chrome browser to get to the Ropieee portal page, you could try using Firefox or Edge. Sometimes the local cache page can have issues with refreshing to a fixed address, like 192.168.x.x

I am just trying everything I can think of. Thanks again for the suggestion. I tried Edge - don’t have FireFox. No help there…

if your units are on ‘ancient’ versions (like 2022.11.2), just re-image them with last version available on

while you do that, check the size of your SD cards - should be at least 8 GB (smaller than that and updates will fail to download / install)

edit: this will not solve your problem if there is a hw / network issue at play, but at least you’ll be on a supported version
hard to believe that suddenly multiple RPi units are failing on you, but you could try swapping good/bad units (power supply as well) to see if issue follows the unit or not

Thanks - I may go that route. Appreciate the support and thoughts, everyone.