RoPieee Incorrectly Id's Allo Piano DAC+ 2.1 as a HiFiBerry DAC

Raspberry Pi 2 B with Allo Piano DAC+ 2.1 is incorrectly ID’s by Roon (endpoint) as a HiFiBerry DAC.
Using RoPieee software. Any idea how to alter RoPieee configuration to reflect proper DAC?
It doesn’t play to full potential and sounds a little wonkee. The problem is not with Roon but in the RoPieee configuration.

Wired Ethernet connection to network, is DHCP assigned, and I can find IP address, but cannot connect to it through any browser. This is my second RoPieee endpoint and the first one went without a hitch. I will give them unique ID’s.

Flagging @spockfish - Harry is the developer of Ropieee; he may be able to help on this…

Hi Robert,

What HAT is selected in the Ropieee web configuration page ? See here for a Guide as to how to configure.

Thank you. I will contact him.

Problem is I don’t have access to the web browser control interface with RoPieee. My network DHCP has assigned the RPI a local IP (wired Ethernet), but I get a connection error with any browser when I try to link with the RoPieee configuration. RoPieee.local doesn’t connect either. My router recognizes the IP when I go there to check connectivity. It does not appear to be a firewall problem.

Can you give me a short troubleshooting list of steps to track down my connectivity issue? I am just skipping around the issue without any real logical direction. Do I need to specify a port location at the end of the IP address in the browser? I tried with Chrome and Firefox.

I have set up 2 other RoPieee end points that work well so I am ok with the procedure. I have read the guide.
Just stumped as to how Roon finds the endpoint, but I can’t get to it from a browser on my LAN.

RoPieee incorrectly ID’s the hat as a “HiFiBerry DAC” during the install. It is actually a Allo Piano DAC Plus or a Piano DAC 2.1 (Seems like they are the same in Allo’s literature).


What happens if you type http://ropieee.local into a browser ?

That’s certainly odd. What does Roon think the IP address is? If you go to Settings/Audio, the IP addresses are given beside each device entry in the Networked Devices section. Is it the same address?

Just for info, I can never get the http://ropieee.local to resolve on my network either - I always have to use the explicit IP address.

For info, if you can connect to the RPi, you should be able to set the HAT being used here: