Ropieee-NG BETA - chat about the new release currently at 2022.01 (RC)

We can chat here about the NextGen Ropieee here. @spockfish

Here’s the image:

Please let Harry know if you are going to run this so he has an idea about names and numbers.


Currently this is quite basic so just bare minimum support but I can confirm wifi is working and USB DAC connections.


I’m trying NG at the moment (buildroot 5.10.77-SPCKFSH-v7l #1 SMP PREEMPT Sat Nov 6). Roonbridge works, SSH too, but I can’t connect to the web interface. Anything special I need to do? @spockfish

Are you trying to connect to the IP address?

No, hostname. Have fixed DHCP and DNS for the Pi. Using the IP works…

ah ok. That’s the problem :wink:

The first beta has the hostname set to ‘buildroot’ instead of ‘ropieee’.

Try that

Naa… avahi doesn’t seem to work in my network. I don’t know why. Maybe it is because I’m using the dns_proxy in my Palo Alto firewall.
Using the IP is fine!

1 Like

Stills runs rock stable on WiFi and I’ve been stress testing it with 192kHz Qobuz a lot. Feels a bit more responsive. The only odd thing is that the host name changes occasionally, like ropieee-bed becomes ropieee-bed-2 in my network (not in the Roon tab). I’m using a static DHCP lease, otherwise defaults.

that name change comes from the M-DNS stack. Seen it myself as well, so I need to investigate.

1 Like

I @spockfish. I don’t seem to be able to get a good image. I am a windows user and I have tried both Etcher and Win32disk imager. I see the card as one disk and run burn the image. When it finishes it turns into 5 drives on my laptop. Add card to Pi4 and it just sits with both lights solid and nothing. I am able to burn good images of production version of Ropieee.

Give Rufus ( a try. Sometimes I have fought with Etcher too on Windows and this has worked.

1 Like

Thanks. Same result. It is a new SD card so I don’t think that is the issue. I don’t want to overwrite my other card that has a working version.

Can rename the file? give it a ‘.bin’ extension instead of ‘.img’.

What browser do you use? Try a ‘save as’ to download the file.

Downloaded fresh using chrome and save as method. Renamed file as .bin.

Burned to SD card with same result. Are others seeing the card partition in to 5 separate drives once the burn is complete?

That is correct, as there are 5 partitions. So that’s not the problem.

@Craig_Cheeseman so this Pi 4 works with a regular RoPieee build?

Yes. I put my other card in and it boots right up as normal. Using regular channel on it.


This would be the first time for you beta testers that you will go through the update cycle of NG. It behaves slightly different, but it should be self-explanatory.


@wizardofoz could you please update the title? and leave the build number (8 right now) out if it as those numbers really don’t mean anything expect for me?

can you send me feedback with that one?

Logs: 75f6019c7e958660

Thanks and sorry to be the problem child.

Update was smooth, but took some time…
One little quirk: the new version appeared different to Roon so I had enable it again in Settings->Audio. Roon then remembered it and name+settings was there.