Ropieee no audio output - how to activate audio-outputs?

I have installed
Raspberry Pi 4 Modell B 4 GB RAM
HiFiBerry Digi+ Pro

Pi4 is with ethernetcable online
Roon shows unit and is playing

But here is no audio out signal on coax and optical

Roon-setting and Ropieee setting

Coax and optical cable are ok
RME adi-2- Pro does not show any input signal

Do i have to do any setting to enable audio output on Hifiberry digi+ pro card?

Connection with sonos - both - optical and coax(AES) are fine

Ropieee has no Signal on RME

Have you tried disabling volume control? So setting it to ‘fixed volume’?

Yes - no audio output

Can you send me feedback? You can find that option on the ‘advanced’ tab.

Also, have you tried different sample rates?

Shouldn’t Audio USB be turned on?

No this is a HAT with coax/spdif out.

1 Like

Logs have been sent to RoPieee HQ with unique identifier bfa2074da84ae2d4

44,1/16 is working
192/24 no output

Ich will do some more testings, what is working and what delivers no output.

192 will for sure not work on optical. That’s usually limited to 96k.

Im am using both - optical SPDIF and coax AES

Mp3 44,1

Both outputs are fine with volume control- fixed volume
Volume control DSP - terrible noise on AES

FLAC 96/24 - fixed volume

FLAC 192/24 - fixed volume

Judging from the pictures above I think you have to change SRC setting on your ADI-2-PRO to SPDIF?

SRC is fine - i am using both inputs
AES for headphone (Rasperry-RME-(StaxAmp)-Headphone)
SPDIF optical for loudspeakers (Rasperry-Antimode-RME-Amp-Loudspeaker)

AES should work with 192
SPDIF optical with 96

If i plug out headphone, RME automaticall switches from AES to optical for loudspeakers.
Each setting has different DAC-Settings and PEQ-Setting on RME - this is a great feature.

So Roon should set ist to 96, or Ropieee should do so.
AES should work with 192.

I think the Digi+ will just output SPDIF over toslink or cinch? The RME is a great device but it is also complicated (I tried it briefly). It think it requires to disconnect the Sample Rate Conversion from the AES input by setting it to SPDIF to work with your Digi+ HAT.
From the ADI-2 manual

8.6 SRC (Sample Rate Conversion)
different clock-sources. For example having the ADI-2 Pro synchronized to an AES signal, a CD player connected to SPDIF input can only be used when the SRC is set to SPDIF. It then decouples the clock of the non-synchronizable CD player, preventing clock problems and drop outs. As the incoming clock phase is no longer fixed when the SRC is activated, the SPDIF Sync state in the State Overview screen will always show lock.

I now updated the kernel, but problem still exists
There is also crackling noise on AES

Logs have been sent to RoPieee HQ with unique identifier 0d45f60f027d91bf

What do you mean with ‘updated the kernel’?

I made some updates on Rasperry with max2play after reading this information (link below)
Hoping to get also rid of the terrible click noise on AEs

Now i have kernel version 5.4.81-2-SPCKFSH-v7l+

@Bart_Koekkoek changed clock source to auto on rme - but did not solve the problem

as per manual it should be set to spdif?

I use Toslink out of a Digi+ Pro HAT on my RPi 3.
Ignore the USB setting. I’m going to add an additional connection, but no USB is connected as yet.



FWIW- According to the HiFIBerry Website, all outputs from this HAT are capable of 192k.

From my Toslink path -