Ropieee not seen on network or roon

Hello. I would appreciate any guidance here if possible…
I have installed both versions of Ropieee (XL and lite) but neither are seen on the network.
Watching the Pi boot sequence, all looks good, it says connected to the internet. Does updates successfully, it says that Ropiee is up and running, then it shuts down the HDMI port.
Fring does not see an Ip address.
Roon core does not see an endpoint.
The green light is blinking slowly and steadily.
My network light shows it is connected.
If I change the boot sd to Volumio it works without a problem. Seen on network and roon as an endpoint, so Pi, wi fi and network is working fine.
Can anybody point me in the right direction please.
Thank you

Harry is on holidays for the next week so he might not reply so fast…but are you still connected by Ethernet? Have you tried to restart it (pull the power wait a min and power up again)?

what RPi model is it? 2/3/3b/4b etc

note that it will only show up in Roon audio settings when there is a DAC connected and powered on or the correct HAT setup.

also you should be able to see it shown in about in roon settings if its got bridge installed.

Grab 2020-08-10 at  18.32.27

Thank you for the prompt reply, yes, all of the above.
It was working fine with Pi3 Boss hat with ropieee lite. I flashed the sd card to ropieee xl and it won’t work.
I reflashed back to lite and still wont work.
As I mentioned it works fine as a roon endpoint with volumio flashed. Puzzling.

Try formatting the SD card and then re-writing RopieeeXL to the card.

Yes, done that and purchased a brand new sd card too just in case, but no joy with both cards.

Maybe try changing out USB cable to DAC and or also plug the cable into a different port.


The Dac is a HAT, so there is no cable, and it works fine as a roon endpoint with volumio, I have tried two ports and again, they both work fine with volumio and the Pi shows up on Fing.
Everything looks fine on the Ropieee boot sequence, no errors, connected to the internet etc, then it does it’s final reboot and disappears completely.
It really looks like a software problem.

One question… how does Ropieee know my ssid and password? There does not seem to be a way to input this.
It wont boot unless it is wired to the network

You need to activate WiFi in the network tab while it’s on Ethernet connection. Both will default to dhcp assigned ip addresses

Mmm… I don’t get an option to do this.

well if you don’t get at least that in the network tab in the ropieee guy you are not going to have wifi

You need to have have it all hardwired during initial setup. You only can use WiFi when you have configured it in the web interface. Plug ethernet back in boot up. Then you’ll find it ipaddress enter that into browser and configure it. You need to save each time you make a change and when set all the things you want reboot to activate them all.

1 Like

Yes, done that. Hardwired during boot.
No ip address on network though, so nothing to enter into browser.
Still seems like a software problem.

No, that is my problem. I can’t see it on the network.

I’m wondering if this is a port speed issue as once ropieee comes up it will drop to 100mbps modes and maybe your switch or router can’t deal with that?

Any info shown on the port of what it’s connected to?

How is it connected to the network? Direct to router or via a switch. I had issues with Cisco switches and Installing Ropieee as the STP caused issues. The switch takes 30secs to test any connection to ensure no issue of a feedback loop and Ropieee would time out due to this and not install properly.

1 Like

Okay, that would make perfect sense. I will connect it directly to the router and take the switch out of the equation.
It does feel exactly like it times out.

No, absolutely nothing. It’s as if it doesn’t exist! Weird

I had a similar issue. I discovered my problem was the dac hat was not fully seated on the pins of the Rpi because I was sent spacers that were too small. Once I corrected this, everything went smoothly. I am guessing this is not your problem as the dac works with other software. are you using wi-fi with volumio?

Is this is a different memory card that was setup as a earlier build?
If so is the NIC setup as static?