Ropieee Not Showing The Web UI

Hi Harry,
I can deal with troubleshooting/installations of mild to moderated complexity (at times with the help of Google) on Win, Mac and on my network/NAS. I once used PuTTY from a Win7 PC to SSH into my RasPi back when I was using the moOde player.
OTOH I just discovered that if I let the browser hanging on for a couple of minutes or so eventually will access the web page. Likewise, once the web page has been accessed, if I try to switch between tabs (General, Advance and Information) it will also take that long to move from one tab to the other.

PS: feedback sent 0d921906ab5d47c4

1 Like

Mines been very slow since the last couple of updates on beta channel and continues on stable. It can hang around a minute or so until the page displays and switching tabs is very slow. I put it down to my router but it looks like it could be Ropieee.

For the record I changed the default hostname as I have two systems to be livingroom and diningroom. Not sure if this is part of the issue.

ok… this is a mystery to me. Logs from @Jose_de_los_Santos seem ok. On my systems it works perfectly.

Now, @Jose_de_los_Santos and @CrystalGipsy would be great if you can test this several times a day to see if there’s a pattern here or this is a continuous issue.


Hi Harry it’s the same for me.
For a long time now I don’t have http access neither by ropiee.local or IP address.
It works fine on roon and I can log on over ssh. I run a port scan and the only available service is ssh.
The morning scheduled restart works fine and I have also tried hard power cycle with no different results
Thanks in advance Vasilis

please login into SSH and run:

pacman -Syu ropieee-web
systemctl enable ropieee-web


Thanks for this Harry
I have tried your suggestion and I get

Errors occurred, no packages were upgraded.
After running the first command and replying yes to both questions

but can you show me output?

ok. you need to reflash, something is damaged on the fs.

Thanks Harry will do this weekend

having the same problem here. Just configured RopieeeXL and everything worked great and was working in Roon no problem. Now I need to setup WiFi and http://ropieeexl.local doesn’t work. Tried directly to the IPN as well, same error. What are my options to just configure WiFi so I don’t have to have it connected to Ethernet? Thanks

Well, the only option is a working web interface.

So you never had access to the web interface at all? Have you tried connecting to http://ropieeexl/

In stead of .local address? And the IP address?


What about SSH or connecting the 7" Pi display directly to the Pi? Can I configure WiFi that way?
No I’ve never had web interface connection to Popieee. I did try the IP address and got the same failure.
I didn’t try http://ropieeexl/ but can when I get home. Thanks

Sorry meant Ropieee. :slight_smile:

No, the 7 inch display is not going to help out here. All configuration stuff needs to happen from the web interface.

Have you tried a re-flash?

No because everything worked great. Recognized and configured Hifiberry DAC and showed up in Roon and played correctly. I can try to flash another SD and try again.

http://ropieeexl/ worked! Thanks
Now when trying to configure WiFi, I check the box and it takes me to the page where I save but I can’t enter anything in the Network and Passphrase boxes.

That’s correct.

It takes 2 steps: first enable and save it. Then go back to the network tab and you can select network and enter passphrase.

I saved and then it took me to screen to input the info. Selected the 1 of 3 networks that showed up the on one network I have and now i won’t connected. Guessing now I have to reflash the card to remove the settings for WiFi so I can connect again to try this all over.