Ropieee on Raspberry Pi 4B WiFi issues

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Library Size

Description of Issue

I didn’t include any Roon details because it’s working fine. This is solely a Ropieee issue.

I just purchased a Raspberry Pi 4B and installed Ropieee.

With the ethernet cable connected I can see the device in Roon and stream to it without issue. I can access the Ropieee web interface where I configured WiFi using a simple SSID with no special characters. I even removed the special characters from the WiFi password. Despite all this if I disconnect the ethernet cable, connectivity ceases.

I started over using a different SD card but the result is the same. I clicked the send feedback in Ropieee and it gave me this identifier 559068f993a5ef21

I have attached a screenshot of the Ropieee WiFi config below.

It’s not clear to me if you are able to access the RPi’s web through WiFi. If not, then the issue is with the WiFi config.

Apologies for the obscurity. Once I remove the ethernet cable the RPi disappears off the network. No connection via the Web interface, can’t ping the name or IP and the device disappears from Roon. Once the ethernet cable is reattached everything returns to normal without further intervention.

Then it’s a WiFi config issue. I’m not using RPi 4, but I have two RPis running RoPieee on WiFi and they work fine. You can try installing RPi OS, set up WiFi using the UI or raspi-config utility and see if that works, to rule out any hardware issues.

Shouldn’t the Gateway be ??


@ Andreas_Philipp1 Well spotted! I was using a secondary subnet because I didn’t want to muck about with the main one and have to reconnect a bunch of TVs, phones, tablets et al. Just after my OP, I remembered about Roon’s single subnet fetish. So I bit the bullet and reconfigured one of the SSIDs on my primary subnet, then connected the RPi to it.

Nothing much changed: With the ethernet connected everything works, unplug it and the wheels stop spinning. The weird thing is that with the ethernet cable in, I see two IPs and can connect to either. Remove the ethernet cable and both IPs disappear.

I forgot to mention that my router sees both RPi IP addresses as “wired” and they share the same MAC address.

Two different physical network devices should never have the same MAC address. If they do, it’s a problem. I’m not proficient in Linux, so you’ll have to search how to check the MAC address of your Ethernet (eth0) and WiFi (wlan0) devices and how to change one of them if they match. Or maybe someone here with Linux skills can tell you how.

Which power supply do you use for the pi? It needs 3 A.


I picked this guy up off Amazon " CanaKit 3.5A Raspberry Pi 4 Power Supply"


Thanks for the RPi OS suggestion. I installed it and enabled WiFi. I had to muck about with the ifconfig command but eventually got it sorted.

If the ethernet cable is in I get two IPs (via DHCP) that share a single MAC address. If I unplug the ethernet cable and restart the RPi, I’m able to connect via WiFi. It shows up on my router with a slightly different MAC address than the physical connection. This is encouraging.

I’m going to give Ropieee one last try (reinstall) and if nothing changes I’ll move on to another linux distribution.

I gave up on the WiFi connection route with Ropieee, it’s simply too unstable. I dug up an unused WiFi extender that has an ethernet port, so I’ll still be using WiFi but connecting to the RPi via it’s ethernet port. Problem sorted.

I would also recommend that anyone using Ropieee should disable WiFi if they are not going to be using it as the OS/device is much stabler sans WiFi.

Thanks for all the help guys, I really appreciated it.

(Deleting; 10 char)


A million times. Get an extender with ethernet connection and forget about it.

1 Like

You can try this, it’s what I usually do:

  • Boot up the first time with Ethernet
  • Connect to it through web browser
  • Set up WiFi
  • Shut down RPi
  • Disconnect Ethernet
  • Boot up RPi


Thanks for the suggestion. Trust me I tried this numerous times and it worked each time using RPi OS but never with Ropieee. As mentioned in my last post, I disabled WiFi via the web interface and used a WiFi extender with an ethernet port and it’s working flawlessly.

1 Like

I have 6 RPi 4B happily running ropieee on WiFi, all set up right first time and permanently connected with no dropouts. Every WiFi link is in excess of 300Mbps. I can assure you there is nothing wrong with ropieee WiFi or RPi built-in Wifi. Either there is a problem with your WiFI access point. Or you are unlucky and the WiFi on your specific RPi is not working. Good that you got around the problem.

1 Like

@Mark_Ebanks Hey Mark, I had very similar issues, I live in an old house with very thick walls and have WifI6 but that all did not help.
In the end I bought for all the ones that had issues this wifi usb adapater (16 € on amazon) : Yizhet Clé WiFi Adaptateur, 1200M WLAN Adaptateur sans Fil AC Dual Band and no issues. In Ropieee you just need to select the ofther wifi adapter. Hope this helps

Despite having enterprise grade WiFi access points, I still hate WiFi. The house walls eat 5GHz WiFi for breakfast, lunch and dinner. Back when I had an ASUS RT-AC68U, I could measure 100% signal strength next to the router, step the other side of an internal wall and not even be able to detect the network SSID.

Everything in the house that has an ethernet port now has a cable connecting it to the main switch. 33 devices and counting… I must have close to half a mile of Cat6 cable installed now.

CAT5E not good enough? Gigabit has been working fine for me. The price delta seems significant.