RoPieee screen not updating


(Harry ten Berge) #21

Hi guys,

Yeah I know how frustrating is, believe me…
It get’s even more frustrating because I can’t reproduce it, how much I try.

What helps is sending feedback the minute you have the situation, and describe it.
Which zone are you listening to, is it actually playing and what to do see on the screen.


(Harry ten Berge) #22

@Geoff_Coupe,

Another question:

  • is this happening directly ‘from the start’? As in: even after a reboot it fails to work properly?

(Geoff Coupe) #23

Hi Harry, Yes I was playing tracks to the zone. The RPi booted up, and got the currently playing track, but then nothing further was updated on the display, despite another hour or two of playing to the zone.

And, yes, this is happening from the start…


(Harry ten Berge) #24

So for the currently playing track all info was there? Artist, title, album and cover art?


(Geoff Coupe) #25

Yes, the first track gets all the info - the cover art, and the point on the playing bar in the track when the display comes on line. And then everything freezes (although touch input in still working) on the display.

Edit: scrolling titles are still scrolling; by freezing, I mean that no new information seems to be coming through.


(Harry ten Berge) #26

ok. I see that actually in the log.

And this state is repeatable? As in: it does this always?


(Geoff Coupe) #27

Yes, it now seems to be permanently repeatable.

Edit: so, for example, I rebooted the RPi yesterday, and the first track came through, and then the display froze again.


(Harry ten Berge) #28

Ok… wow.

Would it be too much to ask if you can do a test where you shutdown all the zones except the Denon one?
So that Roon literally only sees one zone?


(Geoff Coupe) #29

Will do - but I’ve got an appointment in a few minutes that will take me out for the rest of the day. I’ll do this tomorrow and let you know how things go. Thanks.


(Harry ten Berge) #30

ok thanks!


(Geoff Coupe) #31

OK, I’ve done/observed the following:

  1. removed the power from the RPi.
  2. disabled all zones except for the Denon in Roon.
  3. powered up the RPi.
  4. the display came up showing the current state of the queue in the Denon zone (paused 44 seconds in while playing a Sade track)
  1. I pressed Play on the display, and the track continued playing.
  2. the display was frozen in the startup state.
  3. I let the queue continue to see if the display would update on a track change - no result, still frozen.
  4. I paused the queue, and then rebooted the ROCK NUC.
  5. the display then claimed (once ROCK and the Core were up and running) that the zone did not exist, which I thought was odd.
  6. sure enough, the Core had come up in a very bizarre state, with no devices other than Chromecast devices apparently available (I’ve never seen this before)
  7. I restarted the Core Server (I did not reboot ROCK), and this time all the audio devices came up:
  8. the Ropieee display came up showing the current track and the correct point at which it had been paused (a Dusty Springfield track)
  9. I pressed Play on the display, the track started playing - and the display was working.
  10. I re-enabled my other zones, and the display is continuing to work.

So - was there/is there something odd in the Core? Dunno. I do know that a reboot of the Core has not always made the display issue go away. I suppose that I will just have to keep an eye on it. At some point I will be putting the Denon back in a Grouped zone, so I’ll see what happens then as well.

For the moment, fingers crossed, things seem OK. For what it’s worth, here’s the feedback from today’s test: dfba1f0cd6b40e75. Thanks.


(Harry ten Berge) #32

Ok thanks for this test.

I’ve figured out a plan as well: this week I’ll build another extension, with a single purpose only: evaluate all data coming from Roon core.

Your log from earlier shows that the extension is not receiving updates from the core. In other to debug this (and possibly call in the help from the Roon team), I’ll build this evaluation extension that behaves like RoPieee’s original extension, but only logs all info and store this information.

The next time you run into issues I can study these logs.

I’ll keep you posted how it goes.

Thanks,


(Ian Frost) #33

Hi Harry

This is the same with my kit. I’ve noticed that if you restart the extension from the advanced page it catches up, but then doesn’t move on, nor does the track progress show any progress either.

Im not so bothered about that but it would be good to at least have the album art displaying properly.

To make matters worse it stays on, in my case all night, unless i reboot the endpoint.


(Geoff Coupe) #34

Harry, things have been going well for the past couple of days, and the Denon is now in a Grouped zone.

However, today, the “not updating” issue has returned. Here’s the feedback: 9e58e5b9880d06eb

Now, one thing that may be a clue as to what’s going on is that I noticed that the RPi has got a changed IP address in the last day or two. My router is very limited - it’s not possible to reserve DHCP addresses for devices, and I don’t use static IP addresses on any of my devices (perhaps I should?).


(Harry ten Berge) #35

Interesting. But I still would expect that in that case a simple reboot does the trick.


(Ian Frost) #36

Harry

I don’t know if you’ve updated the screen display extension but all seems well today and I’m playing Christmas playlists so lots of different album covers. Even the progress display seems to be performing


(Lloyd Borrett) #37

Any progress with fixing the screen display issue Harry? It’s been so long since it worked properly.


(Harry ten Berge) #38

You are running the latest version? I don’t have recent reports about it nog working.


(Geoff Coupe) #39

Harry, when the display zone is included in a Group, then I’m finding that updating will stop after a while. If I restart ROCK, then it will start working again for a while, but will soon stop updating. When it’s not in a Group, there’s no problem.


(Lloyd Borrett) #40

I’m running the latest version. I run with two zones grouped together. One has a display. Restarting everything gets it working briefly, but it soon stops working.