RoPieee to CXN - Cant play any tracks?

New Roon and RoPieee user, just setup and connected RoPieee to my CXN last night. I am not sure if the problem I am having is a RoPieee or a Roon issue. When I try to play any track in my library Roon tries to play the track and failes and skips to the next track. I have tried changing just about every configuration option possible with no luck.


Roon Core (v1.5) running on Windows 10
RoPieee (V110)
Several Airplay Devices including the CXN that work fine
Oppo 203 that also works fine and what I may just replace my CXN with…

CXN connected to RoPieee using USB Mode 1 - Display shows 96K
Successfully added CXN CA USB audio one device in Roon

unique identifier dd0962c4a35571a3 (Booted RoPiee, started CXN and after connected tried to play several tracks.

Thanks for any assistance!

Your ropieee should be running V110 as it’s the latest. Can you post a screen shot of the ropieee web interface?

Sorry about that, grabbed the version rumber reported in Roon - which is the Roon Bridge version. I am running V110. Updated my original post.

Can you also post the audio settings for that zone in Roon and the audio path screen in Roon when the zone is playing

Usually the “skipping to the next track” problem is caused by network issues, Are you using Ethernet?

I am using Ethernet, I am not able to play anything in the zone so I am unable to capture the signal path but it appears to just show my source track and the RoPieee, I dont see my CXN device in the path. (I Guess that the problem?) Thanks for the help guys! I am going to try another USB cable just for grins.

Ok so the zone looks to be setup ok…but when you play it just skips…as noted this sounds like maybe a network issue. What about if you select max rate to 48k or 44.1?

I tried a different USB cable between Ropieee and CXN and that didn’t help. I have also tried 48K as the max rate and that didn’t work either.

Ping statistics for
Packets: Sent = 50, Received = 50, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 2ms, Average = 0ms

I found this error in the RAAT Server logs on RoPieee for each time Roon tries to play a track.

6/02 07:56:25 Trace: [RAAT::CA CXN USB Audio 1] [lua@0x7380f8f4] [] GOT [26] {“request”:“setup”,“format”:{“sample_type”:“pcm”,“sample_rate”:44100,“bits_per_sample”:16,“channels”:2,“sample_subtype”:“none”}}
06/02 07:56:25 Trace: [RAAT::CA CXN USB Audio 1] alsa output setup: format is pcm 44100/16/2
06/02 07:56:25 Trace: [RAAT::CA CXN USB Audio 1] opening [hw:CARD=C1,DEV=0] 44100/16/2
06/02 07:56:25 Trace: [RAAT::CA CXN USB Audio 1] prefer larger samples = 0
06/02 07:56:25 Trace: [RAAT::CA CXN USB Audio 1] [ALSA] [hw:CARD=C1,DEV=0] using hw pcmformat S24_3LE bitspersample 16
06/02 07:56:25 Trace: [RAAT::CA CXN USB Audio 1] [ALSA] [hw:CARD=C1,DEV=0] Requesting 2 periods
06/02 07:56:25 Trace: [RAAT::CA CXN USB Audio 1] [ALSA] [hw:CARD=C1,DEV=0] Requesting 22050 frames/buffer (11025 frames/period)
06/02 07:56:25 Trace: [RAAT::CA CXN USB Audio 1] [ALSA] [hw:CARD=C1,DEV=0] Initialized with 2 periods with 11025 frames/period and 22050 frames/buffer
06/02 07:56:25 Error: [RAAT::CA CXN USB Audio 1] error in snd_pcm_hw_params: Input/output error (-5)
06/02 07:56:25 Warn: [RAAT::CA CXN USB Audio 1] [lua@0x7380f8f4] [] setup failed: RAAT__OUTPUT_PLUGIN_STATUS_FORMAT_NOT_SUPPORTED
06/02 07:56:25 Trace: [RAAT::CA CXN USB Audio 1] [lua@0x7380f8f4] [] SENT [26] {“message”:“RAAT__OUTPUT_PLUGIN_STATUS_FORMAT_NOT_SUPPORTED”,“status”:“UnexpectedError”}

Hello @Kelly_McRobb,

We are currently investigating issues with the Cambridge CXN on Linux based platforms. I will be sure to update this thread when the Dev and QA teams have further information to share about the issue.


Thanks for letting me know John, Have a good weekend! Same to Nathan and Wiz, appreciate the assistance guys.

OK well next step was just to keep Harry @spockfish in the loop too in case and Support too but as @john has so kindly dropped in I guess thats done :stuck_out_tongue:

As a workaround I think you can use the CXN in USB1 mode. This was discussed on another thread.

Yes I saw that and can confirm, I am using USB1 mode.

Sorry, missed that. Have you power cycled everything after changing the settings?

Yes, multiple power cycles along the way, even unplugging power completely from Ropiee and CXN. Everything seems normal, It wouldn’t surprise me if a recent firmware change by CA might be contributing. CA just recently released a new firmware with Tidal support etc.

Maybe @spockfish will take a look at some point, but it does look like CA’s USB implantation is broken for Linux.

Can you send me feedback? Go to RoPieee’s webpage, the ‘advanced’ tab and hit the ‘send feedback’ button.

Oh, and just to be sure: can you post a screenshot of your Signal Path?


1 Like

Already sent you feedback earlier today in anticipation. I cant grab an audio path since I cant play anything but for a split second -I just see the source track and the Ropiee.

Unique identifier dd0962c4a35571a3 (Booted RoPieee, started CXN and after connected tried to play several tracks.

Let me know if I can provide anything else or help with anything else, thank you!

@spockfish As another data point I installed DietPi and that worked fine. I went ahead and reinstalled Ropiee and sent you some fresh feedback. Unique identifier bba66677995d56ed