Running Roon Remote Android App on Google Pixelbook

Thanks for looking into it. As you mention, the Roon App keeps searching for the Core. I will reach out to Google as well. Appreciate the prompt response.

1 Like

Mike - thanks so much for taking another look at this - this would be the last thing I need to Roon to be absolutely perfect for me (now that Chromecast is working, which is awesome!).

Thanks again,

David

1 Like

Yes Roon,
please, please, please make this work. That would be also for me the last thing needed to be perfect with my chromebook.

1 Like

i have roon core on a mini pc. so far i couldnt connect with the app on my pixelbook. even when i manually filled the path in the required field.
i was successful though, when i initially startet roon on the core bevore i tried to connect with my pixelbook. all of a sudden it connected and i could work in the app.

how i decided to do it: i connect my pixelbook to the pc over remote, then i open roon core on my pc, then close remote window, open roon app and work from there.

If I turn off windows firewall on the server running roon core, the roon remote app on my chromebox works fine, but when I turn the firewall back on it cant connect. I have rules allowing both roon and raatserver thru the firewall, but something else blocks the connection when I turn it on.

Ideas?

I’ve had issues with FW on W10 stopping my Core being able to see the audio devices connected by USB physically on my W10 box. Turn FW off and I can stream to device on W10 machine, turn on FW and it drops. I need to figure out which ports to open and @Tech_Whisky_Lab has posted a link to his GitHub repo (Linux and firewalld) containing a list of ports that need to be opened for communication to work and I think this list will sort out my problem as I also have ROON and RAATSERVER allowed network access.

port protocol="tcp" port="3483" port protocol="tcp" port="9000-9200" port protocol="udp" port="9003" port protocol="udp" port="3483"

I’m going to try opening these ports on my W10 this evening to see if it resolves this issue for me :thinking:

1 Like

I tried to open up a port range but couldn’t get it to work on windows firewall. I can open up individual ports but couldn’t figure out how to put a range in. Been on chromeos for too long lol have blocked out windows tweaking. Let me know if you have success.

You can see how here:

https://docs.microsoft.com/en-us/dotnet/framework/wcf/samples/firewall-instructions

According to those instructions you can enter a list of ports but not a range (9000-9200). Can the ports required be narrowed down enough to be allowed thru a list?

That was where i got stuck trying to allow 9000-9200

Thanks for the help!

Under Windows 10 You can go to Windows Firewall Advanced Settings and you can select port range.
Same for Windows 2008 Server

TY! seems to be working with the firewall up, now.

1 Like

Still need to shut down the core and relaunch daily to get the remote to connect

I think now you are having a different issue worth taking to a new threat. :slight_smile:

Will do. Thank you. I will test it out a few different chromeos devices and see if it is repeatable.

When it connects it works 100%. When it won’t my other remotes connect fine (Android/windows). And as soon as i reboot the core it connects again.

From what I have read in the community seems to be more about the core not being visible rather than the remote not being able to connect.

Will work out the details and start a new thread.

What I’m confused about is I can open a crosh tab on my Pixelbook and ping the ip address of my rock core and it resolves fine. I can also ping “rock” and it finds the host and resolves to the correct ip address. Obviously my Pixelbook can talk to the ip address but Roon can’t find the core. Very frustrating.

1 Like

I have Roon Remote running on a “modified” Kindle HD tablet.

1 Like

This is killing me - I’m now using a Pixelbook and a Pixel Slate - I love them both (mostly) but this is making me crazy - seems so easy.

1 Like

I bought a surface pro 6 vs a slate because of this very issue.

mine has been working for the past few days. running the dev channel on my chromebox.

not sure if it was an update or a fix or on what end it was, but knock-on-wood lol

@Derek_Wyman After I read your reply I tried my pixel book and it connected to the core once and then stopped.