Running Roon Remote Android App on Google Pixelbook


(David Tenn) #21

Any updates or progress on this @roonsupport ?


(David Tenn) #22

@support Any updates now that Roon is streaming to Chromecast devices? Thank you.


(Mike) #23

We can do some more research here, but last time we looked at this the sandboxed networking configuration of Chromebooks prevented Roon from being able to communicate with the Core on the local network.

Obviously, it would be great if something had changed with regards to networking on Chromebooks, but that’s not something we can change, nor does it have anything to do with our Chromecast support.

We’ll take a look and see if anything has changed here, but unfortunately I haven’t heard anything to that effect.


(David Tenn) #24

Thanks for looking into it. As you mention, the Roon App keeps searching for the Core. I will reach out to Google as well. Appreciate the prompt response.


(David Schamis) #25

Mike - thanks so much for taking another look at this - this would be the last thing I need to Roon to be absolutely perfect for me (now that Chromecast is working, which is awesome!).

Thanks again,

David


(Martial Böni) #26

Yes Roon,
please, please, please make this work. That would be also for me the last thing needed to be perfect with my chromebook.


(Martial Böni) #27

i have roon core on a mini pc. so far i couldnt connect with the app on my pixelbook. even when i manually filled the path in the required field.
i was successful though, when i initially startet roon on the core bevore i tried to connect with my pixelbook. all of a sudden it connected and i could work in the app.

how i decided to do it: i connect my pixelbook to the pc over remote, then i open roon core on my pc, then close remote window, open roon app and work from there.


(Derek Wyman) #28

If I turn off windows firewall on the server running roon core, the roon remote app on my chromebox works fine, but when I turn the firewall back on it cant connect. I have rules allowing both roon and raatserver thru the firewall, but something else blocks the connection when I turn it on.

Ideas?


(Binky) #29

I’ve had issues with FW on W10 stopping my Core being able to see the audio devices connected by USB physically on my W10 box. Turn FW off and I can stream to device on W10 machine, turn on FW and it drops. I need to figure out which ports to open and @Tech_Whisky_Lab has posted a link to his GitHub repo (Linux and firewalld) containing a list of ports that need to be opened for communication to work and I think this list will sort out my problem as I also have ROON and RAATSERVER allowed network access.

port protocol="tcp" port="3483" port protocol="tcp" port="9000-9200" port protocol="udp" port="9003" port protocol="udp" port="3483"

I’m going to try opening these ports on my W10 this evening to see if it resolves this issue for me :thinking:


(Derek Wyman) #30

I tried to open up a port range but couldn’t get it to work on windows firewall. I can open up individual ports but couldn’t figure out how to put a range in. Been on chromeos for too long lol have blocked out windows tweaking. Let me know if you have success.


(Fernando Fuentes) #31

You can see how here:

https://docs.microsoft.com/en-us/dotnet/framework/wcf/samples/firewall-instructions


(Derek Wyman) #32

According to those instructions you can enter a list of ports but not a range (9000-9200). Can the ports required be narrowed down enough to be allowed thru a list?

That was where i got stuck trying to allow 9000-9200

Thanks for the help!


(Fernando Fuentes) #33

Under Windows 10 You can go to Windows Firewall Advanced Settings and you can select port range.
Same for Windows 2008 Server


(Derek Wyman) #34

TY! seems to be working with the firewall up, now.


(Derek Wyman) #35

Still need to shut down the core and relaunch daily to get the remote to connect


(Fernando Fuentes) #36

I think now you are having a different issue worth taking to a new threat. :slight_smile:


(Derek Wyman) #37

Will do. Thank you. I will test it out a few different chromeos devices and see if it is repeatable.

When it connects it works 100%. When it won’t my other remotes connect fine (Android/windows). And as soon as i reboot the core it connects again.

From what I have read in the community seems to be more about the core not being visible rather than the remote not being able to connect.

Will work out the details and start a new thread.


#38

What I’m confused about is I can open a crosh tab on my Pixelbook and ping the ip address of my rock core and it resolves fine. I can also ping “rock” and it finds the host and resolves to the correct ip address. Obviously my Pixelbook can talk to the ip address but Roon can’t find the core. Very frustrating.


(Thomas Becker) #39

I have Roon Remote running on a “modified” Kindle HD tablet.


(David Schamis) #40

This is killing me - I’m now using a Pixelbook and a Pixel Slate - I love them both (mostly) but this is making me crazy - seems so easy.