Running Roon via Wine on Linux

Nope, it worked pretty much flawlessly. The installation took a few minutes though, but eventually succeeded. I have had one crash so far (I forgot to take a screenshot of it at the time).

So I thought I’d try to get this working on my Manjaro installation… My first step was to read the readme, ha, what a concept, and see what the dependencies are. Thats where I am stuck, all I see in pamac manager is WINE 5.22…

Would someone mind helping me, just a tiny bit to get this up and running? Thanks.


Try the following instructions to make downgrade Wine to version 5.11.

Downgrading packages – Manjaro

Then just run the script, you can do it like this:

bash <( curl -s

Best regards,

Thank you, I did a search for wine stable and am using that, and lo and behold, its working… in Wayland. It didn’t want to work in Plasma, it said my screen was too small, but it works fine in Wayland.


5.22 also works fine (in Fedora in my case), see the post from Rahul_Garg. However, in Wayland, keyboard input is very sluggish, e.g. using search. Xorg works fine, no crashes in ~ 2 weeks.

Good to know about 5.22.

For me, Xorg did not work, I got a message about my screen being too small, and to either go fullscreen or maximize, neither of which worked.

Also, in Wayland and my keyboard response in Roon is not sluggish at all.

Anyway, it’s 2:16am here and way past my bedtime, so I’ll work on it more tomorrow.

You no longer need to downgrade wine to 5.11. Newest version of roon-on-wine works without a hitch on wine 5.22

1 Like

Retried wayland, works fine.

After a restart, Roon works just fine in an Xorg session as well as Wayland.

Is there a pressing reason I should upgrade my wine to 5.22 now that I have it working just fine in the stable release 5.03?

There might be some performance improvements

I upgraded to WINE 5.22 and all went smoothly. Has anyone updated Roon itself yet with the new update out today? Any problems?

I’m on WINE 5.22 too and just updated Roon to Build 710 an hour ago.
All is fine so far.

1 Like

Great to hear, thanks!

Are you running the core on a separate machine? I am only using the Roon on Wine as a remote, my core runs on a Euphony OS based server.

Yes, I’m running ROCK on a separate device.
Using Roon on Wine only as remote too - on two different devices.

1 Like

Awesome. I am going to go ahead and do it. Whats the worst that can happen… right? :wink:

Fortunately, I’ve never had any problems after updating Roon so far, except that I had to adjust the desktop shortcut again some time ago. But that problem has also been solved in the meantime.

Good luck!

Well… I wasn’t so lucky. Selecting “maximized” or “fullscreen” doesn’t change anything. It also does the same thing in a Wayland session. Anyone have an idea of how I can fix this?

Ok. Strange that it worked before.
I avoid the resolution problem width auto-hiding my task bar.