Running Roon via Wine on Linux

I’ve wanted a full Roon UI on Linux since I first took out a subscription.

My core runs on a Linux box that handles audio and video requirements and sits with my hifi system. I usually control it via my laptop. Over the last year or so I’ve had to use Windows 10 to get Roon functionality or use an Android tablet. I would normally use Linux on my laptop so I’ve never been really happy with this.

Earlier this week I found this thread: Ubuntu 17.10 64bit RoonServer with Roon on WINE I followed the instructions and got Roon working under wine on Linux Mint 18.3. The really surprising thing is that it runs quicker and smoother than on Windows 10 using the same laptop and performs much better than the Android app.

I was so impressed I thought it deserved a new thread so that others could try it.


Thanks for sharing. Just installed Wine and Roon on Manjaro (ArchLinux) and do have the same surprising experience: Roon remote runs smoother and quicker using Linux/Wine (compared to Windows10 on the same laptop). And even the touchscreen of my Lenovo Yoga X1 works excellent with Roon!

Did use the great install script you get over here: and only had to modify the startup script to set scaling to 2x for hi resolution screen.

I am using Roon trial subscription and one issue why I was doubting about buying Roon has been solved: Linux support for the control app is available, although it requires some hacking.


Ubuntu with i3-gaps here.
On 32bit winearch:
Tidal artwork loads correctly but Roon itself hangs 2/3 times. Does not respond to Mod+Shift+Q, has to be killed with xkill.
Resizing the window (either by spawning another window or by changing gap size) crops the window instead of actually resizing it.
Focusing the window (either via mouse or keyboard) causes it to flash white for a split second.
Quitting Roon and then starting it again via .desktop file causes a page fault (can provide logs if anybody is interested). Works fine when started via
On 64bit winearch:
Window still flashes white when focused and it does page fault when started from .desktop file but works fine aside from that.
Conclusion: set winearch to win64 to avoid a headache.

Kudos to author of roon-on-wine script, it makes it so much easier than setting up the environment manually.

EDIT: Works fine when started from .desktop file after I changed the Exec line from wine-stable to wine.

1 Like

Could you share startup script to set scaling to 2x for hi resolution screen, I had 4K Dell so need your help.
I install on Manjaro 18.1 and getting crash rather frequently.
Thank you.

Cmon, NO need to run Roon with Wine…THEY MAKE A LINUX SERVER!!! Google it… runs GREAT as a core…SOUNDS TERRIFIC!!!

I think this thread is more about the Roon GUI than the server.

You use the GUI in your remote control…your phone, tablet, or whatever…Let the core run on the server!!

Hi @Kim_Coffey,
I’m afraid we’re not talking about exactly the same thing. With the desktop/full version - let’s leave the included server aside - (in my case the Windows version) of roon you will have the following advantages, which you don’t have with a tablet or a phone:

  • Export your music files with the Roon provided metadata
  • Export your music library to an excel file
  • Adding convolution files
  • Editing with keyboard and mouse (no tipping on touchscreen), which I think it’s more comfortable
  • Bigger Screen
  • Roon UI runs smoother in most ways

If you don’t need the facts I’ve mentioned, you don’t have to fiddle around with it.

Of course my roon core is running on a linux machine, which is less or more just a server, without the UI.

Here is my startup script with scalefactor setting at the end to support high resolution screen:

env WINEPREFIX=/home/jacob/my_roon_instance wine /home/jacob/my_roon_instance/'drive_c/users/jacob/Local Settings/Application Data/Roon/Application/Roon.exe' -scalefactor=2

I do not experience any stability issues, while using Manjaro with KDE desktop and Wine 4.2 (I only use Wine for Roon and forced it to version 4.2 because more recent versions causes issues).

1 Like

I’ve been having extremely limited success getting 1.7 to run, anyone else?

If it previously worked for you, then maybe your mono/.NET version is 4.5.0 but 4.5.2 is required.

My current installation runs fine:


Kernel 5.0.0-36-lowlatency; Wine-4.0.2; .NET 4.7.2, Roon 64-bit

Edited the install script to use dotnet452 and it seems to work now, thanks.

Working well on Pop_OS - thanks for the script.

Works on Gentoo. Note you need unstable Winetricks (20200412 works for me) to install dotnet.

If anyone else is struggling with installing the Roon GUI with the roon-on-wine script, there was a bug in Winetricks that prevented the installation of the required dotnet libraries, which in turn messed up the Roon installation. It was fixed last week and using the latest version allowed me to finally successfully install the Roon GUI on Linux Mint. Works great so far.


For anyone who is trying to get Roon to run on wine in Arch and having troubles, I posted an issue on github that might be helpful. (It could also be helpful to anyone trying to get Roon to run in the newest versions of wine.)

1 Like

Hi @Bob_Torres,

I’ve pushed out a long-standing update that takes your issue into account as this also made my install work on a Fedora build with Wayland (which I’m running currently).

So thanks!

Works with no issues on Manjaro with Wine 5.11, thanks spockfish

Just here to report another successful run on linux using roon-on-wine.

Kernel: 5.9.11-3-MANJARO
Wine: wine-5.22 (Staging)

Startup script:

env WINEPREFIX=/home/rahul/my_roon_instance wine /home/rahul/my_roon_instance/'drive_c/users/rahul/Local Settings/Application Data/Roon/Application/Roon.exe' -scalefactor=1

Hopefully linux gets first party remote support at some point, till then running it on wine seems to get the job done pretty much flawlessly (at the cost of some extra RAM).

1 Like

Did you run any issues during dotnet installation on wine 5.22?