Ubuntu 17.10 64bit RoonServer with Roon on WINE

It’s much more likely that someone can help you if you post the actual errors you get.

Sorry about that.

This is as far as I got before closing it:


There is always a huge bunch of warnings and errors (see also: Difficutly installing Roon 1.7 on Ubuntu 18.04.3 LTS using WineHQ [in this example installation run winetricks alone generated 2.1 MB of log output messages]).

Did you abort the script execution? Maybe you should just let it run until completion and see if it terminates with an error code or not (Note: the installation of all the .NET packages can take some time depending on your hardware – go eat something/watch a series episode/watch a movie/listen to an album/… while you wait). Maybe it’s best to delete any unfinished winprefix (’/root/my_roon_instance’) before you try again.

PS: Looks like you’re logged-in as root. Are you sure about this? You should be logged-in as the user that want’s to use the Roon Control later on and run the script with sudo as the installation goes to the current users home directory.

Works on Ubuntu 20.04. Just make sure you run “sudo apt-get install wine winetricks winbind” before running the script from @spockfish.

Nice job, @spockfish!

1 Like

Hi guys,
First a big thanks to all of you and especially to spockfish of course!
Mixed experience on Fedora 32. I managed to install (with a whole bunch of errors, but that’s normal I gather - no error exit in any case), but roon doesn’t start. Splash image is shown but when charging done, a window frame (that supposedly should contain the app) flashes briefly and it all disappears and exists. So that looks like the dotnet issue discussed here prior to the last update of the script.
I put my install log here
… and my start log here
Since I’m a completely blank paper concerning wine, I would immensely appreciate if anyone could have a look to see what might be the issue and why the solution implemented in the last script update doesn’t work. Or could anyone tell me how to practically implement Alfredo’s hints above, especially 5 and 6?
Best wishes

Hi @Matthias_H,

I’ve recently switched myself to Fedora 32 (coming from openSUSE), but you seem to got more results then I did. On my system it already stops when it tries to run the Roon installer:

002c:err:module:__wine_process_init L"Z:\\home\\harry\\dev\\ROPIEEE\\roon-on-wine\\RoonInstaller64.exe" not supported on this system

I will look into this, but I’m worried this is related to Fedora running on Wayland.

Agree that Wayland might be a culprit - I stayed on Xorg (relying heavily on autokey). So that might be part of an explanation why I got further.

I’ve successfully installed Roon on Wine and it works great. But I have a huge problem.

I can’t disable autoupdate. So, whenever it updates, wine can’t find it anymore because it’s looking in a folder that doesn’t exist. How can I prevent it from updating?

I guess it’s better to remove the unneeded portion of the path that causes this from the link you use to startup Roon (read above in the posts from 2018).

What distro are you running? What desktop? I had that problem running Cinnamon on Linux Mint.

Got my new Linux laptop. Installed Roon on it. Works!

Can also confirm I have Roon Remote running on my Ubuntu 20.04 test laptop. Thanks very much @spockfish @Adam_Woodbridge I was worried about the flood of error messages while the script was running but took @spockfish 's advice and enjoyed a cup of coffee. Now enjoying Roon Remote on Linux - how good!

I recently switched to Manjaro stable with Xfce (was on Debian testing previously).
Wine and other utilities are from official Manjaro repository (currently Wine v5.12 after a global upgrade).
The script, and Roon control 64, work very well.

Note that on the first launch of the script, I got an error after just a few minutes (a bad checksum of a downloaded Microsoft package, could be a network glitch).
I relaunched the script and all was ok (after about 25 minutes of logs).

Many thanks @Spockfish

After the recent Roon 610 update, when I attempted to open Roon Remote via the desktop shortcut using Ubuntu 20.04 and Linux Mint 20 I got -
There was an error launching the application.
Details: Failed to change directory “home/mark/my_roon_instance/-dosdevices/c:/users/mark/Local Setting/Application Data/Roon/Application/-100700571”(No such file or directory)

It would seem this is because the file path after the 610 update is
"home/mark/my_roon_instance/-dosdevices/c:/users/mark/Local Setting/Application Data/Roon/Application/-100700610

The simple fix is to delete the path in the Roon.desktop file. That is, in my case, delete: Path=/home/mark/my_roon_instance/dosdevices/c:/users/mark/Local Settings/Application Data/Roon/Application/100700571

The Roon.desktop file then reads
Exec=env WINEPREFIX="/home/mark/my_roon_instance" wine-stable C:\\windows\\command\\start.exe /Unix /home/mark/my_roon_instance/dosdevices/c:/users/mark/Start\ Menu/Programs/Roon.lnk

However, Roon in the application launcher does not respond but it does activate after Roon is launched via Roon.desktop. Hopefully, this fix will not have flow on ramifications. Maybe @spockfish could confirm. I presume that this fix is what @BlackJack was referring to in the earlier post of 14 June.

Maybe it is just as simple to open Roon via the Terminal or the file manager using “start_my_roon_instance.sh”

Sorry, but I can’t confirm.

I’ve switched to Fedora and since that I’m not able to run Roon in Wine anymore. I’ve spend a huge amount of time trying to get it to work, but without success.

In general I would say that I would use ‘start_my_roon_instance.sh’ also from the .desktop file, as this prevents duplication.

You only need delete the reference to the final folder in the path statement, in your case the /100700571 Leave the rest of the path intact. After this any further updates will run from the desktop link without needing to change anything.

My start menu entry for Roon doesn’t work either. I’m on Mint 19.3 Cinnamon. I couldn’t be bothered to find out why as the desktop link works fine. I use it all the time and have had no problems.

Thanks for your advice @eclectic. It didn’t seem right to entirely delete the path. As you have had no problems, I have gone with your fix.

Given @spockfish comments, an alternative is the following:

On Mint 20 Cinnamon, you could set up a Roon desktop shortcut by right click on the desktop, select Create new launcher here, Name: Roon, Browse to start_my_roon_instance.sh

The .desktop file reads

Then change to Icon=7E1D_Roon.0

Using Ubuntu 20.04.1 - create the above .desktop file. Copy it to the desktop, and right click on file and select Allow Launching

I’m running pop OS which is Ubuntu.

I don’t know how to disable the auto-update for Roon, which breaks my Wine install.

Useful information for Arch users in the quoted post.

I’ve pushed out an update.