Ubuntu 17.10 64bit RoonServer with Roon on WINE


(Aaron Skog) #1

I really tried to get my trial working. The problem I have is that I do not have a Windows or Mac available to install the client. The RoonServer installed on my Ubuntu 17.10 64 bit desktop, but my attempts to get WINE to work with a Windows7 install of Roon was problematic. I wiped out my WINE install twice, and I suspect with some other additional work I could get it going. The WINETRICKS was used to add the .NET 4.5 requirement, and I used a Windows drive mapping to point to my ext4 partition that holds my digital music. This would be fun to figure out if I had more time, but I fear that I would be running such a non-standard arrangement that it would not be stable or be susceptible to breaking during my OS upgrades. I appreciate what Roonlabs is doing-- I think a limited browser based admin interface is key to at least get the server pointed at the music collection and the basic config complete, and the mobile android app would take it from there.


Running Roon via Wine on Linux
Docker images for Roon
(Daniel Beyer) #2

The android tablet app does the basic server configuration.


#3

Hi @Aaron_Skog

I have a stable roon install with wine running on Linux Mint.
First I had to add the winehq sources. Here is the description how to do it.
Then I installed winehq-stable 3.x.x (older versions of wine didn’t work for me).
Before installing you should delete your older wine version.
Rename or delete your old wine folder in the home directory.
The trick that made it working was to first install roon and after that all the .NET stuff.

This was my starting point.

Everthing is working fine so far except of some small graphical issues.

Good luck.


(Danny Dulai) #4

The Roon UI works?! WINE has reasonable OpenGL support?


#5

Yes it works. Here is a screenshot plus some of my system specs:


(Danny Dulai) #6

how does it perform?


#7

Starting takes 5 to 6 seconds. After that 1 second more to load the images. Browsing is smooth, better than as with my tablet.


(Danny Dulai) #8

what spec of machine/video card and what type of tablet?


#9

It’s a Lenovo TAB 2 A10-70F with Android 6.0.
CPU MT8165, 4 Cores, 1,7 GHz
RAM 2 GB
Did you mean machine/video card of my tablet or laptop?
Don’t get me wrong. The Tablet is working fine. But my laptop with roon on wine is running a bit smoother.


(Danny Dulai) #10

laptop specs…


#12

Here are my laptop specs:

System: Kernel: 4.13.0-32-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) dm: lightdm Distro: Linux Mint 18.3 Sylvia
Machine: System: Hewlett-Packard (portable) product: HP 350 G1 v: 0992100000400010000634101
Mobo: Hewlett-Packard model: 21B7 v: KBC Version 46.0B Bios: Insyde v: F.12 date: 06/12/2014
Chassis: type: 10
CPU: Dual core Intel Core i3-4005U (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 6784
clock speeds: min/max: 800/1600 MHz 1: 1696 MHz 2: 1696 MHz 3: 1696 MHz 4: 1696 MHz
Graphics: Card: Intel Haswell-ULT Integrated Graphics Controller bus-ID: 00:02.0 chip-ID: 8086:0a16
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1366x768@59.99hz
GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 17.2.4 Direct Rendering: Yes

Hope this helps.


(Alan MacLeod) #13

Adding my laptop as I too had remote running under wine - currently not using for unrelated reasons.

HP 8440p (circa 2009/2010)
Intel Core i5 M540 @ 2.53GHz
Integrated graphics “HD Graphics”
1366x768 and 1680x1050 monitors
Samsung 850 EVO SSD
8G of RAM
Debian Buster
Lightdm 1.18
XFCE 4.12
Xorg 1.19.6
Kernel 4.14.0
Wine 3.0

Apart from some instability in maintaining connection to the core, it runs fine. This is my daily use PC and is rarely less than 70-80% memory usage so instability may be a byproduct of swapping.


#14

My installation is very stable, except I set my laptop to sleep for more than one time. Than roon closes. But that’s not a big deal for me.
I like the addition of the “windows” version to export excel-tables and music-files. Both are working fine for me.

I prefer my laptop for editing my collection.


(Ben Zipperer) #15

Wow, your instructions worked for me – so nice to have a Roon control running on my laptop! Thank you!

I’m running Fedora 27 Gnome desktop on a 2015 Thinkpad X1, i5-5300U, 8GB of RAM. This laptop is separately running the linux version of Roon Server.

In order to get the Roon UI running in wine I needed to install mesa-dri-drivers.i686 and mesa-libGLU-devel.i686. Also I needed to use the winehq-stable version of wine, like @florib mentioned.


#16

@florib Thanks for the excellent post.

I now have a fully working Roon “Remote” using Wine and Linux Mint. This was the one thing I needed to complete my Roon installation. Previously I had to use an android tablet to get remote functionality if my laptop was running Linux or had to boot to Windows.

Here’s the working proof :slight_smile:


#17

Nice to hear that it’s working for others too. :grinning:


(Harry ten Berge) #18

Confirmed on OpenSUSE as well.


#19

@florib, are you running Roon 64 bit or 32 bit? I’ve tried to install and run on Arch, which uses Wine 3.7-1. Trying to launch the 32 bit version throws:

0009:fixme:mscoree:parse_probing privatePath=L"100400316" not implemented
0009:err:module:load_builtin_dll failed to load .so lib for builtin L"l3codeca.acm": libmpg123.so.0: cannot open shared object file: No such file or directory

Unhandled Exception:
System.TypeLoadException: Could not load type of field 'Sooloos.Application+<>c__DisplayClass3_0:prop_selectedlang' (1) due to: Could not load file or assembly 'RoonBase, Version=1.0.6689.5122, Culture=neutral, PublicKeyToken=null' or one of its dependencies. assembly:RoonBase, Version=1.0.6689.5122, Culture=neutral, PublicKeyToken=null type:<unknown type> member:<none>
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeLoadException: Could not load type of field 'Sooloos.Application+<>c__DisplayClass3_0:prop_selectedlang' (1) due to: Could not load file or assembly 'RoonBase, Version=1.0.6689.5122, Culture=neutral, PublicKeyToken=null' or one of its dependencies. assembly:RoonBase, Version=1.0.6689.5122, Culture=neutral, PublicKeyToken=null type:<unknown type> member:<none>

I’m guessing it could well be because I’m using LXDE as my desktop rather than Gnome.


#20

Nope, same unhandled exception using Gnome.


#21

@evand, I’ve got the 32 bit version of roon running, although my laptop is a 64 bit one and I’m using wine 3.0.0. I’m not shure, but I think i can remember that I couldn’t install the 64 bit version of roon.
It could also be possible that a newer version of wine doesn’t work. I tried some different versions and winehq-stable version was the only one which worked.
Maybe you can try a live version of linux mint or a similar distribution to play around with other graphical interfaces.

@spockfish, what gui have you running?