Ubuntu 17.10 64bit RoonServer with Roon on WINE


(Harry ten Berge) #22

32 bit. The 64 bit is not working afaik. And yeah, you need to run wine-stable.

the exception I see that @evand has is the same exception I got when running the 64 bit version.


#23

@spockfish strangely enough it’s the 32 bit version I’ve installed thinking the 64 bit install was unlikely to work well under Wine.


(Harry ten Berge) #24

hmmm… ok. did you follow the instructions in the other post? Installing dotnet and have a separate wine environment for Roon alone?


#25

This one?
https://community.roonlabs.com/t/roon-control-linux/23081/14


(Harry ten Berge) #26

yes that’s the one.


#27

I uninstalled wine, removed /home/user/.wine, reinstalled and followed that thread and it’s up and running now. Thx. The key seems to be in creating a custom environment for Roon only.


#28

I’ve collected some information and made an instruction about installing roon on wine. Any suggestions are very welcome.


#29

Looks good, here’s a summary of what I did in Arch:

Ensure 32 bit libraries are enabled:
https://wiki.archlinux.org/index.php/multilib

Create a directory in ~/ (I used .wineRoon):
mkdir /home/x/.wineRoon

Create the Wine instance:
env WINEPREFIX=/home/x/.wineRoon WINEARCH=win32 wine wineboot

Set the Window version to Win7:
env WINEPREFIX=/home/x/.wineRoon winecfg

Install .Net 4.5:
env WINEPREFIX=/home/x/.wineRoon winetricks dotnet45

Install Roon (previously downloaded)
env WINEPREFIX=/home/x/.wineRoon wine ~/Downloads/RoonInstaller.exe

To run it use the following (with the correct path to your username (mine is x)
env WINEPREFIX=/home/x/.wineRoon/ wine /home/x/.wineRoon/drive_c/users/x/Local\ Settings/Application\ Data/Roon/Application/Roon.exe

To launch it via Roon’s desktop icon right click on it and paste in the above line in the Command entry dialogue:

image


#30

Tried the same using a 64 bit Wine and Roon and it fails on launch and it fails on running it due to failure to load DLL’s. Seeing as it works in 32 bit mode, I won’t pursue the 64 bit build any further. It’s great to finally have a fully functional Roon client in Linux. Let’s hope the Roon team at some point deem it important enough to provide. I don’t buy the Linux desktop environment complexity line.


#31

@evand has added his instructions to the document I’d postet above. If any other is interested in adding further information or correct something please write me a p.m. and I will give you write access.


#32

The update to Roon 1.5 trashed my Wine Roon. I uninstalled Roon using winecfg and reinstalled version1.4. It’s working again. I’ll try again with a fresh install when the links on the download page are updated to 1.5


#33

Hi @eclectic, I’d updated my Wine Roon through the ui (Settings --> Info (or About)). Everthing is working fine so far. Have you tried to start Roon from the terminal, maybe you can see any hints what’s wrong.


(Harry ten Berge) #34

Mine is not capable of updating. We’re talking about the 32 bit version. It says it can’t get the proper information. Someone a clue?


#35

I’ve got mine going now @florib @spockfish

This is what happened to me today:

Roon alerted me to the updates in the usual way. I did my core on another linux box and a Pi I use for headphones. No problems.

Then I did the Wine 32 bit update through the Roon automated process. It worked fine and I started trying out a few albums and MQA etc. After about an hour, it crashed and dumped me back to the desktop. I tried to restart but it kept saying that it couldn’t find the correct directory.

I removed Roon with winecfg and then downloaded a fresh 32 bit from Roon’s download page. However, they hadn’t at that time changed from ver 1.4 to 1.5 on the download links.

This meant I was back to square 1 with version 1.4.

After florib said he had it going, I gave it another try. Allowed Roon to auto update, it worked until I quit Roon, then refused to restart when I clicked the desktop or toolbar shortcut.

I went to the Roon files and found that the numbered directory in the screen shot below had changed with the update. Wine was complaining about this and looking for the previous directory which I guess was for version 1.4 ??

If I used "open with " wine when I right clicked roon.exe in the application directory it ran. I just had to create a new desktop shortcut.

However, it doesn’t run quite as smoothly. There is a slight “wobble” when scrolling the album covers. As they come to rest on a new screen.

Also you might notice from the screenshot that it’s running in a standard .wine instance. I don’t run any other wine applications on this laptop though.


#36

@spockfish As you can see in the screenshot my Wine Roon is the 32 bit version (first entry).

@eclectic
That’s strange. I hadn’t to do anything after the update, but hadn’t listen to music for an hour or longer before. I do it right now.
I’ve running a separate core with R.O.C.K. on an Intel NUC. My guess was, that my separate linux core could be a possibility. But you’ve a separate core too. Maybe R.O.C.K.?
I have noticed in the past that the links to the installation files are not updated in a timely manner. I think the best way to update roon is to use the graphical interface respectively the automated process of roon.
My roon is as smooth as before, could be a bit better. Not very good, but ok.


#37

My core runs on a silent fanless PC, Linux Mint, Core i7, 16gig of ram and an ssd. I use it for Roon, Netflix, Amazon Prime etc. Video via HDMI to the TV. Audio via usb to a DAC and my hifi system.


#38

No issues upgrading here, it even relaunched itself.


#39

@eclectic

Just to confirm and for information:

  • I have the same folder as you with the same name, but no other one.
  • Had the operating system on which Roon Win is running restarted several times during music playback and without - no problem.
  • Closed the roon app several times
  • Playing music for over two hours now with mixed content: tidal flac + mqa, local flac cd + hi-res.
  • I still have more windows software running, but in the standard folder (.wine) not the separately created roon folder.
  • Desktop or toolbar shortcut are still working for me.

The roon log file says:

AvailableVersion={ MachineValue=100500320 DisplayValue='1.5 (build 320) stable' Branch='stable' } CurrentVersion={ MachineValue=100400310 DisplayValue='1.4 (build 310) stable' Branch='stable' } }

“100500320” is the name of the new folder after update, “100400310” the older one. So the folder name has changed.

I can remember I had a similar issue with the shortcut some time ago. It was also a problem with the path after updating roon. The generated shortcut during installation was not working anymore.

So I changed the entry in “/home/user/.local/share/applications/wine/Programs/Roon.desktop” looking like this (remember to change the wine-folder 5 times):

[Desktop Entry]
Name=Roon
Exec=env WINEPREFIX="/home/martin/WinRoon" wine C:\\\\windows\\\\command\\\\start.exe /Unix /home/martin/WinRoon/dosdevices/c:/users/martin/Start\\ Menu/Programs/Roon.lnk
Type=Application
StartupNotify=true
Path=/home/martin/WinRoon/dosdevices/c:/users/martin/Local Settings/Application Data/Roon/Application
Icon=93CE_Roon.0
StartupWMClass=roon.exe

With this entry you should’t have any issues with future updates.

Could you confirm any differences in your file?

P. S.: I hope the roon guys will give us a native linux client in the future.


#40

@florib

Here’s my Roon.desktop file. It was hardwired to the version 1.4 directory. I guess that’s why it failed. It was auto generated when I first installed Roon.

[Desktop Entry]
Name=Roon
Exec=env WINEPREFIX="/home/martin/.wine" wine C:\\windows\\command\\start.exe /Unix /home/martin/.wine/dosdevices/c:/users/martin/Start\ Menu/Programs/Roon.lnk
Type=Application
StartupNotify=true
Path=/home/martin/.wine/dosdevices/c:/users/martin/Local Settings/Application Data/Roon/Application/100400310
Icon=5B23_Roon.0
StartupWMClass=roon.exe


#41

@eclectic
I’ve got the problem that roon closes if i set my laptop to sleep for more than three times or if my network connection is broken.

So I think after updating your system roon was running fine as long it closes itself.

After that you had a wrong shortcut and it would not open anymore.