Ubuntu 17.10 64bit RoonServer with Roon on WINE


#42

@florib I deleted the reference to “/100400310” in the roon.desktop file path and it now runs perfectly from the shortcuts.


#43

Nice to hear :grinning:.


(Harry ten Berge) #44

Just installed it on my new Dell XPS with openSUSE. This time with the 64 bit version. Works like a charm!
Still somewhat amazed on how good this actually performs.

Now, someone needs to wrap this in a flatpak or one of those other ‘new thingies’ and we’ve got ourselves an ‘out-of-the-box’ Roon on Linux experience :wink:


(Jan Koudijs) #45

Oh yes, a Docker image would be nice.


(Larry Post) #46

(Jan Koudijs) #47

Hi @Larry_Post,

I know there are Docker images for the Roon Core.

This would be a Docker image for the Roon Remote, i.e. the remote app for Windows running under Wine on e.g. an Ubuntu base image. The challenge might be the OpenGL stuff. Maybe there is a better tool to achieve this.


#48

Hi @spockfish,

how did you get the 64 bit version running?


(Harry ten Berge) #49

Just following the procedure earlier mentioned. I did nothing different then with the 32 bit version.
The only thing that might be different than earlier attempts is that I run the latest Wine (3.9), which is just a few weeks old.


#50

@spockfish
Thanks. I will try it soon.


#51

Hi, all.
I’ve got now the 64 bit version of roon running too, but couldn’t notice any advantages (speed) on my machine.
I had no luck with the instructions posted earlier. If anyone is interested on how i did it, here are the updated instructions on how to install roon on wine.


#52

I have a new laptop. I installed Linux Mint 19 (64 bit). Once again I followed the guide by @florib .

I can report that 64 bit Roon on Wine works very well as a remote. I haven’t tried using the laptop as a Roon endpoint.

I did have a problem installing it though. Firstly, I forgot to use the bionic main repository (at WineHQ). My first attempt using xenial ended in dismal failure :slight_smile:

Having got this step right, apt-get refused to load packages from the repository saying it was unsigned and consequently insecure. It claimed that no keys were available.

I nuked the Wine installation and tried again from the beginning. This time it worked. It’s fast and responsive.

Laptop specs:
Linux Mint 19 64 bit Cinnamon desktop
Core i7 8550u
Intel UHD 620 graphics
1920x1080 FHD display
16 gig of Ram
500 gig Samsung Evo 970 Pro m.2 (nvme) SSD


#53

Hi @eclectic,

did you know that a script exists for the automatic installation of roon under Linux by @spockfish :

https://github.com/RoPieee/roon-on-wine

I’m on Manjaro Linux now and it was working fine for me.


#54

Interesting, didn’t work for me on this machine.


#55

@evand

What exactly?


#56

Script installed, but roon doesn’t launch, haven’t yet tried to look into it


#57

If you do not already know, a script named “./start_my_roon_instance.sh” will be created, which will allow you to start roon from the terminal.

I can remember that the shortcut generated by the roon installation did not work for me and I modified it a bit.

My desktop entry looks like this:

[Desktop Entry]
Comment=
Exec=env WINEPREFIX="/home/x/my_roon_instance" wine C:\\\\windows\\\\command\\\\start.exe /Unix /home/x/my_roon_instance/dosdevices/c:/users/x/Start\\ Menu/Programs/Roon.lnk
Icon=93CE_Roon.0
Name=Roon
NoDisplay=false
Path[$e]=$HOME/my_roon_instance/dosdevices/c:/users/x/Local Settings/Application Data/Roon/Application
StartupNotify=true
StartupWMClass=roon.exe
Terminal=0
TerminalOptions=
Type=Application
X-KDE-SubstituteUID=false
X-KDE-Username=

Maybe here is your problem somewhere. Good Luck.


#58

Thanks, I did try starting with that script. Will have a look over the weekend.


(Harry ten Berge) #59

Yeah let me know, because it would be great if this script becomes more usable on different setups.


(Neil Carpenter) #60

I had an issue with the script as I didn’t have winetricks installed. I submitted a PR on GH to include that in the initial checks.

(Otherwise, it seems to have worked for me on Ubuntu 18.04.)


(Johan) #61

Roon is installed, but I have no sound?

SOLVED.
I have now a 100% working Roon on my KDE Neon linux system

I used the script by @spockfish for automatic install.