Ubuntu 17.10 64bit RoonServer with Roon on WINE


(Harry ten Berge) #62

Thanks @Neil_Carpenter.
Merged!


(Harry ten Berge) #63

Would be great guys if we can make a list of distributions and versions that we can confirm it works on.
With that we can extend the script as well.


#64

Arch Linux with LXDE here.


(Johan) #65

KDE Neon here


#66

Manjaro (Arch based) with KDE.


#67

@spockfish THX for the install script, works wonderwell on Manjaro (ArchLinux) with KDE.

Only had one problem: very small characters and images, due to lack of scaling for my hi-resolution screen.

However, I was able to fix this by modifying the Roon startup script start_my_roon_instance.sh and passing roon.exe a scale argument as suggested in this post https://community.roonlabs.com/t/windows-requires-full-screen-setting-a-custom-scale-factor/35450:

#!/bin/bash

PREFIX=/home/woody/my_roon_instance
env WINEPREFIX=/home/woody/my_roon_instance wine /home/woody/my_roon_instance/‘drive_c/users/woody/Local Settings/Application Data/Roon/Application/Roon.exe’ -scalefactor=2


(Johan) #68

Still a pitty that there is no fully bloated Linux version for .deb or .rpm based Linux or even a tar.gz.
I hope Roon will eventualy make one!


(Harry ten Berge) #69

Thats not gonna happen. On many occassions this has been explained by the Roon team.


(Harry ten Berge) #70

Hmmm… unfortunately for me it’s crashing with the upcoming Wine 4.0.
I’m on RC2.

Someone else already playing with Wine 4.0?


(Johan) #71

And what exactly did they explained?


(Harry ten Berge) #72

well, you can search right? :wink:


(Johan) #73

I’m a bit lazy today… :wink: But yeah, you’re right…


#74

Yesterday I had no problems installing Roon using your script and Wine v4.0 rc4. Did a clean install of Wine, no older version.


(Harry ten Berge) #75

hmm. ok. I upgraded Wine, maybe that’s the issue.
I’ll try a fresh reinstall as well.


(Duncan Simpson) #76

Thanks @spockfish for this script, it saves a lot of time and hassle to try Roon Control on Linux.
I found a few issues (Wine 4.0 on Manjaro 64-bit with KDE with video-linux display driver), so I’ve forked the repo and I’m working on a fix.

  • Tidal artwork doesn’t render. I’m no .Net developer, but the logs show what possible look to be SSL/TLS errors connecting to get the artwork. Resolved by using 64-bit installer.
  • random crashes rendering new views. Also seems to be resolved using 64-bit installer.
  • Full screen view on multiple monitor setup with vertical stacking (ie external monitor above laptop screen) extended to fill both monitors instead of current monitor (like it does on Windows 10). Also resolved using 64-bit installer.

I’ll create a pull request when I’m happy its all working smoothly.


#77

Hi @Duncan_Simpson,
I have almost the same setup as you except that I run wine 4.2.
I’m just trying out your fork and it seems that it actually runs a bit more fluently, especially regarding the TIDAL and QOBUZ artwork.
I previously had the problem with the @spockfish script that the artwork did not render properly and managed to convince myself that I just reinstalled roon.
I’ve tried to get the 64-bit version of roon running before, but as far as I could remember, there were conflicts with .net.
In any case, thank you both for your work.


(Ben D) #78

Running Roon on Manjaro :slight_smile:

Thank you to the lovely person who made this work.

Artwork and other images from tidal don’t seem to be working, is this to be expected?

EDIT: looks like it is, and is already being worked on. Awesome!


(Harry ten Berge) #79

Hi @Duncan_Simpson,

What about that PR? :wink:


(Harry ten Berge) #80

@RBM, as this original topic has been a little bit of hijacked (me guilty as well :wink: ) would it not be a good idea to add a ‘Wine’ section to the forum?


(Ben D) #81

Just change the wine installer to 64 and the wine arch to 64, the rest takes care of itself.