Windows Requires Full Screen: Setting A Custom Scale Factor

Can you try the workaround I suggested here:

If you need help setting that up, just let us know.

I assume you mean 2160, and not 21160.

If I do resolution divided by 3 (300%), then I get a virtual resolution of 1280x720 for your device – Roon cannot run on 1280x720 – and the fact that you have a taskbar fixed at the bottom, means you are actually getting less than 720 tall.

Fullscreen mode works because draws over the taskbar, and hides the top statusbar too, so you get exactly 720 tall, which is just barely enough.

The good news is that your options are simple and plentiful:

  1. change your scale factor in Windows
  2. change the scale factor in Roon with a command-line parameter (-scalefactor=2)
  3. you can run fullscreen.

The link @mike posted above has instructions on how to do both of the first 2 solutions.

1 Like

Hi Danny

As said earlier if I reduce the scaling to 250% then Roon works properly but every other programme is reduced in size so that they are difficult to use. also the link you provided to force the scale factor does not work it complains that the path either wrong or theres a spelling mistake


Hey @Mike_Durham – can you show us exactly what you’re typing, and where?

Hey Mike – thanks for clarifying. I think I see the issue here. Bear with me and we’ll get this right for you.

Try this:

  • In Windows, open the Run dialog (just type Run in the start menu)

  • In the Run dialog, click Browse

  • Navigate to the Application folder of your Roon database
    (this will be something like C:\Users\ [your user name] \AppData\Local\Roon\Application

  • Click Roon.exe

  • Now you should have the correct path in the Run dialog – for me it’s:

  • Put that path in double-quotes and then add the scale factor modifier to the end – I get this:
    "C:\Users\mike\AppData\Local\Roon\Application\Roon.exe" -scalefactor=2

  • Launch Roon and see if things look better – if not, open the Run dialog, click the little down arrow to find your previous command, and change 2 to something else, like 3, like this:
    "C:\Users\mike\AppData\Local\Roon\Application\Roon.exe" -scalefactor=3

  • Repeat until things are scaled how you’d like

Let us know how that goes, and we can help if you have any more trouble here ok? Thanks!

@Mike_Durham - I also have a Yoga 910 laptop that has a 3840 x 2160 resolution, and with the scaling set at 250%, Roon and all the other applications that I use on it work perfectly, and are not too small, even for my failing/ageing eyesight. It may be that at least one of your daily applications is not written to take advantage of Windows scaling, and therefore appears at a vastly reduced scale on this UHD display. Is it possible that this is the case?

Hi Geoff

Yes I agree that everything works at 250% but I find the text size for my eyes to small to use comfortable and for an extended period. I use excel a lot for a sports club I help run and I could not do the work I do now with the scaling set at 250%. I take a very simple approach to these things if 99% of what I do works why should I change settings to account for the 1% that doesn’t.


In one of your earlier replies you pointed me to other question and answers regarding this problem and said to try the suggestions in those replies one was to type onto the run box :-
data\local\roon\application\roon.exe -scalefactor=2
so I did,
I’m not a computer wizz kid nor a tech guy just a retired gent trying to use a piece of software that I have paid for. Yes I can use it but not in the way it was designed to be used.



This is getting silly, if I start Roon from the run box the scalling has an effect but it takes ages to connect to the remote core, but if I start Roon from the short cut on the desktop the scaling has no effect but it connects to the remote core straight away. confused


Yup the instructions above are just for figuring out the correct scale factor for you.

Once you know that, right click the Shortcut and copy the same command (from the Run dialog) into the shortcut’s “Target” field – then Roon should open up with your custom scale factor every time.

There shouldn’t be any connection here. I doubt this will happen every time, but let us know if it does and we can take a deeper look.

Using a custom scale factor like this is pretty uncommon, which is why the steps are a bit convoluted. That said, once you get this working I’m guessing you won’t have to think about this any more.

Let us know how it’s going and we’ll make sure we get this right, Mike. Thank you!


I’ve found using a scalefactor=2.5 works and that has been applied to the shortcut. It still seems to longer to connect to the core but that could be my network.
thanks for your help


If this persists, let us know and we can take a look. Glad you’re all set here Mike, thanks!