Sample Rate Conversion Grey'd Out

Hello all,

I have been using a schiit ygg for a while now with no issues and recently got a McIntosh MHA100 and now im having a issue of not being able to change the Same rate conversion. It is turned on is the DSP presets but it does not give me the ability to configure how roon manages output samles rates.

Any help would be amazing. thanks!

Hi @PS1,

Can you please post a screenshot of the behavior you’re seeing? You can upload screenshots to Community by using the “image upload” button:


– Noris

hello, yes here you go. Thanks for the help!


I can’t see that screen use the upload button (looks like a landscape) which will embed the image.

Hello, yes that is what i did.

(Try this link.) Looks like it worked great. As you can see Sample rate Conversion is grey’ed

Thanks for the replies!

Hi @PS1,

Do you by any chance have exclusive mode disabled for that zone? I would check in Device Setup.
Also, not sure what system you are using but if you are using Windows I would check to make sure that you have installed the driver from McIntosh’s site

– Noris

Hello, thanks so much for the reply. Yes i have exclusive move enabled. I am using windows 10 and have the latest version of the Mcintosh drivers. I have two options it seems WASAPI and ASIO (not sure if thats related.

anything else i can try/look at?

Thanks so much for the help so far.

Hello @PS1,

Sorry for the delay, the ASIO driver should work fine for your setup. There is one other thing that we can try here, if you go to Roon Settings -> Audio -> Cogwheel icon next to affected zone -> Device Setup -> Advanced -> Toggle “Work around devices that misreport capabilities”

This is what the setting looks like:

Can you please let me know if that helps with Sample Rate Conversion?


No worries on the delay. Ok followed the direction but it i still greyd out and i am unable to make any changes. :frowning:

AH! ok i think that might have worked? - when in WASAPI mode i am not able to change it, When swapping over to the ASIO zone it can make the change! Is there any huge difference between the two? (asio vs wasapi)

Thanks again!

Hello @PS1,

Glad to hear that it is working for you with ASIO drivers! You can read about the differences in WASAPI and ASIO here and here but if ASIO is working as expected I would stick to using that method of communication.