Sample Rate conversion with compatibility only does not change signal path

Core Machine (Operating system/System info/Roon build number)

Intel I7 Roon core (1.6 (416)) running ubuntu server 18.04

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Wifi from Nuc to Core, Core is connected to the router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Intel Nuc (Roon bridge V1.0 build 1.69) running ubuntu 18.04 connected to Schiit Yggdrasil with USB

Conversation rate is set to compatibility mode only, with smooth minimum phase, but signal path shows this:

This is the DSP setting:

Is this normal?

Yes that is expected as there is nothing to convert here because your Yggdrasil supports the 44.1kHz source stream. There is no need to introduce the sample rate converter in the signal path with your current settings. Available setting are:


For Compatibility Only = Down-sample the source stream if its sample rate exceeds the maximum supported sample rate of the device or else do nothing.
Max PCM rate = Ensure that the sample rate of the stream matches the maximum supported sample rate of the device.
Custom = Configure your own rules.

Since roon says

question is : if it converts the signal to Smooth minimum phase , and if the answer is yes, why the signal path does not show it?

NOTE: These settings are also taken into account when conversions are performed for compatipility reasons.

With the sample rate conversion policy set to ‘For Compatibility Only’ there is no sample rate conversion going to happen until the source stream’s sample rate exceeds the maximum supported sample rate of the device. There is no such thing like conversion to ‘Smooth, Minimum Phase’ because ‘Smooth, Minimum Phase’ is a filter that gets applied to the sample rate conversion process (if it happens). At least that’s my understanding of this matter.

Maybe @support is able to shed some light into the darkness?

Maybe the KB-article DSP Engine: Sample Rate Conversion can be supplemented with an explanation of the different sample rate conversion policies so one can refer to it in the future if similar questions should arise?

BlackJack is correct. The phase filter is for when Roon is up or downsampling. Your doing neither at the moment with using the Compatibility setting. That setting is purely to use on low end devices that do not support higher sample rates or have a fixed sample rate. Roon will then only adjust as needed. Your DAC can handle sources up to 192/24.

Thanks @CrystalGipsy. @support please confirm

Hello @Shahryar_Sedghi,

The information given by @BlackJack and @CrystalGipsy is correct, thanks guys!

Just to give a quick overview:

When the “Sample Rate Conversion” is set to “For Compatibility Only”, it will only be enabled when you are playing a track that your DAC would not be capable of playing natively.

For example, let’s say that your DAC is only capable of playing up to 96kHz PCM content. What would happen if you tried to play 192kHz content to the DAC? With the “For Compatibility Only” option enabled, Roon would automatically sense the limitation and downsample the 192kHz content to a 96kHz stream.

While doing this conversion, it would use the chosen “Sample Rate Conversion Filter” for this process.

To summarize: When the Sample Rate Conversion is set to “For Compatibility Only”, the Sample Rate Conversion will not be active unless you are playing content that your DAC does not support natively.



Thanks @john Is there a way to apply any filter without up or down sampling?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.