Samsung Galaxy S9+ keeps disconnecting

Core Machine (Operating system/System info/Roon build number)

Windows 10 Pro x64, Intel Xeon CPU E5-1680, 64GB of RAM, Roon Version 1.6 (build 416) (64bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Router DrayTek Vigor 3220 connected to Netgear GS724T switch connected to DrayTek VigorAP 910C

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Q Acustics Active speakers connected via optical cable to the above PC, Denon AVR X6300H, Samsung Galaxy S9+

Description Of Issue

My phone (Samsung Galaxy S9+) keeps disconnecting from roon core when I play my music through the phone. There are no issues with playing music through Active speakers or Denon AVR even if I use my phone as remote.

Hi @Wojciech_Motyka,

Can you let me know if this behavior occurs for all sample rates or only for certain kinds of rates/media? How is your Core connected here, is it over WiFi or Ethernet? Is there any change if you try plugging it in via Ethernet if it is currently on WiFi?

– Noris

Hi Noris,

This issue occurs to different sample rates, but it’s only when I use my phone to listen to music.
My core is connected via ethernet to the switch which is connected via ethernet to the access point. my phone is connected over wifi to the access point.
I haven’t noticed any wifi dropping on my phone nor on any other wifi devices connected to the access point.
There are no issues when I play music with my Denon AVR or my nVidia shield (both connected via ethernet to the same switch as the core).

Hi @Wojciech_Motyka,

Thanks for letting me know that information. Can you please let me know the exact local time + date when this behavior next occurs on your Android device? E.g. 9:57PM on 6/10/19?

I would like to take a look at the diagnostics from your Core + Remote to see if perhaps there are any clues as to why it may be occurring.

Is your Galaxy S9+ the only Roon Remote in use in your setup, or do you have another Roon Remote you can try this behavior on? E.g. iPad or another PC running Roon in remote mode?

– Noris

Hi Noris,

The problem occurred today (2019-06-11) at 08:20 (CET) - roon app on my android phone lost connection to my roon core.
Yes, I have another roon remote - my laptop with Windows 10 Pro - and I have not reported any issues with it so far.


Hi @noris,

I have just noticed something interesting, it seems that roon app on my Galaxy S9+ crashes only when I lock my screen, when the phone is unlocked it seems to be working fine. I have noticed that today when I put my phone into wireless charger and did not lock the screen.
Additionally I have disabled battery optimization for roon app in the phone settings.

I hope that will help you with debugging.
Please let me know if you need more information.


The app closing or crashing when display is off is quite common on Android mine does it more often than not. I have battery optimisation off too. I don’t have music stop or anything when this happens though.

Make sure your phone is not configured to turn off WiFi when it’s asleep or display off as this will cause playback to stop.

Thank you for your comment @Simon_Arnold3, it’s pointed me in the right direction. My WiFi is set to be always on, but maybe there is some setting that I’ve missed so far that makes roon or WiFi to stop. I will do some more investigating. For now I’ve just settled for using roon on my phone with the screen unlocked … not the best option but at least I can enjoy my music without any interruptions :slight_smile:

Yeah its not great. I used to have this issue on my Galaxy Tab S2, not sure what I did to get it to work, but I have always on Wifi, battery optimisation off. It works perfectly fine now.

Also as there is no bit perfect playback on Android as the system os will resample everything to either 48/24 or 96/24 (on my Tab S2) in the background, I have found by using DSP to upsample to the devices native rate and it improves performance as I would get glitches when screen was off or interacted with other apps when Roon in background. Now its sounding better and no glitches.

@Simon_Arnold3, thank you for suggestions! I will give it a try.

Hi @Wojciech_Motyka,

You can try to adjust the settings as @Simon_Arnold3 has noted but if that does not help, I want to mention that we have an active investigation regarding this issue, and the devs are currently working on some improvements to our Android app.

I can’t comment on when the new version of the Android will be published, but just wanted you to be aware that work is in progress on this area of the Android app and am hopeful that it will help in your case as well.

Hi @noris,

I have used the settings that @Simon_Arnold3 suggested and I also switched ‘performance settings’ on my phone to ‘entertainment’. I haven’t had any issues with looking connection ever since.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.